Airport Extreme Admin Utility

Discussion in 'Mac Accessories' started by kevinr621, Mar 2, 2010.

  1. kevinr621 macrumors newbie

    Joined:
    Mar 2, 2010
    #1
    I am trying to set up an Extreme with the admin utility and I am getting an error message that says that the version of software is not compatiable with the version of extreme that i am using... is there a new version of this utility out there?
     
  2. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #2
    Yeah there are several of them... there's plain old Airport Utility which I believe is the newest. There's also an older version for the older AE's... which model Extreme do you have?
     
  3. kevinr621 thread starter macrumors newbie

    Joined:
    Mar 2, 2010
    #3
    Model

    It is the newest version A1354... I am setting up 7 AppleTV's and would like to use a few extremes' to act as relays... and i will need to use the admin utility to enable the device as a WDS... is there another way to do this without the admin utility?
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    The newest version is the one that came with your Extreme. Install it from the disc that was packaged with your router. The new Extremes do not work with the AirPort Utility that came installed with Leopard/Snow Leopard.
     
  5. kevinr621 thread starter macrumors newbie

    Joined:
    Mar 2, 2010
    #5
    That is what I did... I am seeing that there are 2 software applications... one is the Airport Utility that comes with the device, and there is another application called Airport Admin Utility, that enables you to configure the device in a more advanced mode... the one I d/l from Apple seems to be an older version and not capable of communicating with the newest extremes...
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
    You shouldn't download anything from anywhere. The software disc that came with the Extreme is the latest version you need. The online version is not the latest version and will not work. The version on the disc is AirPort Utility 5.5. The latest online version is 5.4.2 (which does not work with the new Extremes). Anything earlier than 5.5 will not work.

    Also, AirPort Admin Utility is the old name for AirPort Utility, so you are indeed downloading an old, deprecated copy of the software you need (which is on the disc).

    Edit: While it usually is safe to assume that the online version of a particular software will indeed be the latest version, that's not the case in this situation. Apple has yet to release 5.5 online since the debut of the simultaneous dual band Extreme and Time Capsule.
     

Share This Page