Airport Extreme Guest Mode - Error

incoherent1

macrumors member
Original poster
Jun 5, 2007
72
0
I'm creating a guest network on an airport extreme and getting the error "No Internet Connection". When I check the IP in SysPrefs, there's nothing there: no IP address, no router address, etc.

The extreme is in Bridge mode, and it's connected to a simple modem with only one Ethernet port (aka. it's not a modem/router combo).

The original (non-guest) network works fine.

Any help is hugely appreciated!
 

opinio

macrumors 65816
Mar 23, 2013
1,171
4
I'm creating a guest network on an airport extreme and getting the error "No Internet Connection". When I check the IP in SysPrefs, there's nothing there: no IP address, no router address, etc.

The extreme is in Bridge mode, and it's connected to a simple modem with only one Ethernet port (aka. it's not a modem/router combo).

The original (non-guest) network works fine.

Any help is hugely appreciated!
I have my modem set to bridge and have the AE set to do everything. So the AE does the PPPOA connection to the ISP, and runs the DHCP Server and also runs the wifi. I have no problem setting guest in that config.

Also, you could try restarting but that is unlikely to fixit.

Or worst case, do a factory restore. I find that works well with my airport expresses sometimes because they can be temperamental.
 

jay47

macrumors member
Apr 8, 2012
58
27
The reason your getting the error is because you have the AE in bridge mode . The only time you would use bridge mode is if you are using a combo modem/router or are using another device to handle dhcp & routing.

Airports are very picky about having the correct settings .

Change the internet setting to ethernet , ethernet wan port to automatic , connection sharing to share a public address.
 

incoherent1

macrumors member
Original poster
Jun 5, 2007
72
0
The reason your getting the error is because you have the AE in bridge mode . The only time you would use bridge mode is if you are using a combo modem/router or are using another device to handle dhcp & routing.

Airports are very picky about having the correct settings .

Change the internet setting to ethernet , ethernet wan port to automatic , connection sharing to share a public address.
Thank you!
 

asaini007

macrumors newbie
Nov 17, 2013
1
0
The reason your getting the error is because you have the AE in bridge mode . The only time you would use bridge mode is if you are using a combo modem/router or are using another device to handle dhcp & routing.

Airports are very picky about having the correct settings .

Change the internet setting to ethernet , ethernet wan port to automatic , connection sharing to share a public address.
I'm a total novice at all things home networking. Basically I'm having the exact same problem as OP, but I have no idea how to access these settings in the AirPort Utility application for my AirPort Extreme. Do I use that application or something else? Thanks
 

priitv8

macrumors 68040
Jan 13, 2011
3,543
447
Estonia
Do I use that application or something else? Thanks
You can't use anything else, really. And for novices, it has a wizard, that does a pretty good job on discovering the environment you've deployed your ABE in and setting up the device correctly.
E.g. it discovers ABE being behind a NAT router and sets ABE up properly in bridge mode.
 

Jefe's MacAir

macrumors 6502
Nov 21, 2010
492
309
I'm a total novice at all things home networking. Basically I'm having the exact same problem as OP, but I have no idea how to access these settings in the AirPort Utility application for my AirPort Extreme. Do I use that application or something else? Thanks
Click Launch Pad

Click Airport Utility

Click on Base Station- This will open a floating window containing some information about the Base Station.

Click Edit

Click Network- Turn Router Mode: Off (Bridge Mode)

Click Update

If already in Off (Bridge Mode) turn it back on to DHP and NAT and click Update. You'll likely end up with a Double NAT warning. You can click ignore.

You can always go back. Although when you're on the Guest Network your Airport Utility won't see the Airport/Time Capsule. You'll need to be on the main/admin/original network.
 

Samurai!!!!!

macrumors newbie
Sep 27, 2015
1
0
Click Launch Pad

Click Airport Utility

Click on Base Station- This will open a floating window containing some information about the Base Station.

Click Edit

Click Network- Turn Router Mode: Off (Bridge Mode)

Click Update

If already in Off (Bridge Mode) turn it back on to DHP and NAT and click Update. You'll likely end up with a Double NAT warning. You can click ignore.

You can always go back. Although when you're on the Guest Network your Airport Utility won't see the Airport/Time Capsule. You'll need to be on the main/admin/original network.
Thanks a lot dude. This worked for me!
 

T2tnt

macrumors newbie
Jan 6, 2016
1
0
Parts Unknown
Worked for me. I can no longer see the air express I have as part of the network, but it still functions as an independent network. The primary network, and the "guest network" are working perfectly so far. thanks


Click Launch Pad

Click Airport Utility

Click on Base Station- This will open a floating window containing some information about the Base Station.

Click Edit

Click Network- Turn Router Mode: Off (Bridge Mode)

Click Update

If already in Off (Bridge Mode) turn it back on to DHP and NAT and click Update. You'll likely end up with a Double NAT warning. You can click ignore.

You can always go back. Although when you're on the Guest Network your Airport Utility won't see the Airport/Time Capsule. You'll need to be on the main/admin/original network.