Airport Extreme Guest Network Not Working

Mork

macrumors 6502
Original poster
Jan 9, 2009
422
14
Hello,

I have and airport extreme. Today I tried to enable the guest network.

The Airport has NAT and DHCP enabled which are the default.

The Guest Network was WPA2 Personal configuration.

When I then enabled the guest network I got an IP address that started with 172 so it naturally did not connect.

Read some postings online, but none seemed to fit this situation.

So, if anybody can tell me what I need to do to make the guest network actually connect with the regular IP address that would be great. :)

TIA

- m
 

LiveM

macrumors 65816
Oct 30, 2015
1,131
518
You can't use the guest network unless you connect it to a pure modem, not a modem router.
 

Mork

macrumors 6502
Original poster
Jan 9, 2009
422
14
You can't use the guest network unless you connect it to a pure modem, not a modem router.
Huh? You mean hook up the router to a 19.2 Zoom modem connected to a, gulp, land line?

Nothing in the Airport Extreme seems to indicate I'd need to do this so I'm sure I am missing your point.

Thanks

m
 

LiveM

macrumors 65816
Oct 30, 2015
1,131
518
If the Extreme is not the first router in the link, it cannot control the network like that. See if you can set the modem router to bridge mode.

https://support.apple.com/en-nz/HT204590
  • The DHCP and NAT option in AirPort Utility application > Network tab > Router Mode (default mode) must be selected on your primary base station, and Off (Bridge Mode) should be selected for any other AirPort base stations on the network.
You need to be in bridge mode if your modem router is not.
 
Last edited:

Mork

macrumors 6502
Original poster
Jan 9, 2009
422
14
If the Extreme is not the first router in the link, it cannot control the network like that. See if you can set the modem router to bridge mode.

https://support.apple.com/en-nz/HT204590
  • The DHCP and NAT option in AirPort Utility application > Network tab > Router Mode (default mode) must be selected on your primary base station, and Off (Bridge Mode) should be selected for any other AirPort base stations on the network.
You need to be in bridge mode if your modem router is not.
I have a single Airport Extreme that we use for our network. DHCP and NAT are the default. All I want to do is to enable the guest network on the Airport Extreme, but apparently I don't know what that means. I enabled the guest network and selected WPA2, but when I connect to that network via WiFi (same Airport Extreme Router), I get a non reachable IP address (172...).

Does this clarify my original posting?

I'm still confused why this won't work. I was thinking the single Airport Extreme would just create another range of IP addresses (or, for the guest, at least one IP address) separate from its other network, but I'm probably missing your point.

- m
 

Brian33

macrumors 6502a
Apr 30, 2008
730
39
USA (Virginia)
I think you've got it set up correctly. I'm pretty sure devices on the guest network are supposed to get 172.xxx IP addresses. That shouldn't be a problem -- a device on the guest network should still be able to get to the internet.

It sounds like you are trying to reach the device on the guest network from a device on your "regular" network. I don't think you can do that, and it's intended to work that way. The two networks are kept separate, and devices on one can't "see" those on the other.

For me, that was the main reason I set up the guest network. We have two cheapie Android tablets that have known security vulnerabilites, and the manufacturer won't provide an OS update. I wanted to isolate them so that if the tablets are compromised the attackers would still not have LAN access to our other devices. Of course, it was also nice that I felt comfortable setting an easier to remember WPA2 password which I give to guests. Guests usually want to access the internet but don't need to access any of my network devices (possibly excepting the printer, I guess).

LiveM is referring to a problem that does come up a lot regarding guest networks. People (including me at first) try to use the feature when the Airport is in bridge mode and/or there is another router involved (e.g., and ISP WiFi router). But it sounds like you've got the Airport enabled for NAT and DHCP and it's the primary router. Should work.
[doublepost=1460778263][/doublepost]Just noticed in Airport Utility, you can specify the guest DHCP range. Go to Network-->Network Options-->Guest IPv4 DHCP Range, and you can choose from 10.0 or 172.16 or 192.168

(I see mine is the 192.168 range and I could have sworn it was the 172.16 range! My regular network is the 10.0).

So it looks like you can choose the same subnet as your "regular" network.

Hope that helps.
 
Last edited:

rigormortis

macrumors 68000
Jun 11, 2009
1,813
229
the way guest network is supposed to work is the guests get a different subnet. that way they can browse the internet but they are not allowed to browse your other computers, servers and printers.

like maybe regular network is 192.168.1.xxx and the guest is 192.178.2.xxx or 172.16.1.xxx
 

Mork

macrumors 6502
Original poster
Jan 9, 2009
422
14
I think you've got it set up correctly. I'm pretty sure devices on the guest network are supposed to get 172.xxx IP addresses. That shouldn't be a problem -- a device on the guest network should still be able to get to the internet.

It sounds like you are trying to reach the device on the guest network from a device on your "regular" network. I don't think you can do that, and it's intended to work that way. The two networks are kept separate, and devices on one can't "see" those on the other.

For me, that was the main reason I set up the guest network. We have two cheapie Android tablets that have known security vulnerabilites, and the manufacturer won't provide an OS update. I wanted to isolate them so that if the tablets are compromised the attackers would still not have LAN access to our other devices. Of course, it was also nice that I felt comfortable setting an easier to remember WPA2 password which I give to guests. Guests usually want to access the internet but don't need to access any of my network devices (possibly excepting the printer, I guess).

LiveM is referring to a problem that does come up a lot regarding guest networks. People (including me at first) try to use the feature when the Airport is in bridge mode and/or there is another router involved (e.g., and ISP WiFi router). But it sounds like you've got the Airport enabled for NAT and DHCP and it's the primary router. Should work.
[doublepost=1460778263][/doublepost]Just noticed in Airport Utility, you can specify the guest DHCP range. Go to Network-->Network Options-->Guest IPv4 DHCP Range, and you can choose from 10.0 or 172.16 or 192.168

(I see mine is the 192.168 range and I could have sworn it was the 172.16 range! My regular network is the 10.0).

So it looks like you can choose the same subnet as your "regular" network.

Hope that helps.
Good information, but when I go into Network and then Network Options, I don't see anything about "Guest" for the DHCP range.It just says: "IPv4 DHCP Range:" And, the only range shown is for my internal DHCP addresses.

Do I have an out of date router or something?

- m
[doublepost=1460807050][/doublepost]
the way guest network is supposed to work is the guests get a different subnet. that way they can browse the internet but they are not allowed to browse your other computers, servers and printers.

like maybe regular network is 192.168.1.xxx and the guest is 192.178.2.xxx or 172.16.1.xxx
Right, but it's not working that way at the moment.

I'll need to do some additional testing.

Thanks,

- m
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
Good information, but when I go into Network and then Network Options, I don't see anything about "Guest" for the DHCP range.It just says: "IPv4 DHCP Range:" And, the only range shown is for my internal DHCP addresses.
What version of AirPort Utility are you using? With the guest network enabled, the settings for the IP addresses for the guest network should appear. Keep in mind that the guest network should have a separate IP range than the main network and be limited to internet access while the main network supports file sharing.
 

Attachments

Mork

macrumors 6502
Original poster
Jan 9, 2009
422
14
What version of AirPort Utility are you using? With the guest network enabled, the settings for the IP addresses for the guest network should appear. Keep in mind that the guest network should have a separate IP range than the main network and be limited to internet access while the main network supports file sharing.
Yes, you're right. Once I enable the guest network, then I see the guest IPs.

However, connecting via Wi-Fi to the guest network still does not work. The only thing I can think of to try at this time would be to reset the router to factory defaults and see if that would help. From other searches I've done with others with this same problem, that factory reset seems to have helped some of them.

:(

The Airport Extreme firmware version I have is: 7.7.3.

Thanks,