Airport Extreme has Self-Assigned IP, blocking wireless Linksys connection

Discussion in 'macOS' started by sara.sia, Mar 12, 2011.

  1. sara.sia macrumors newbie

    Joined:
    Mar 12, 2011
    #1
    Let me make this COMPLICATED issue as clear as I possibly can:

    1. I am using my brand new iMac with a Linksys AT&T router. Have been fine with my internet for months.

    2. Today I tried connecting my Airport Extreme Base Station (old model from 2002) to my Linksys router

    3. At the installation process in Airport Utility, I selected to "replace my existing network with my airport" (I think this was my mistake here)

    4. Things started looking funny fast, I lost my Linksys connection and also my Airport connection - no internet

    5. I immediately unplugged the AEBS and reset my Linksys router, ditching the whole AEBS

    6. THE MAIN PROBLEM: My husband's SONY Vaio and my Macbook Pro both can still connect to our Linksys wireless signal, but my iMac CANNOT CONNECT (This is the computer I completed the set up of my Airport Utility with the AEBS originally)

    The computer says that "airport has the self-assigned ip address and will not be able to connect to the internet"

    However, I can connect to the internet on EVERY OTHER computer in my network except one: the computer I originally installed the AEBS on.

    7. I have tried everything (and read all the forums!) including:
    -Verified that we are configuring the IPv4 using DCHP
    -Configuring the IPv6 automatically

    - Then I tried assigning a manual IP address within the range that my router owns and specifies

    also tried this (per another forum):
    1. Go to Mac/Library/Preferences/SystemConfiguration
    2. Delete the following:
    a. Com.apple.airport.prefrences.plist
    b. NetworkInterfaces.plist
    c. Preferences.plist
    3.Shut down computer
    4.reset PRAM

    NOTHING HAS WORKED. How can I get my iMac to claim the proper IP address?

    I am absolutely baffled at this, and I am a very proficient tech. I have never seen anything like this before. PLEASE HELP! What is going ON???
     
  2. cozmot Guest

    Joined:
    Mar 16, 2008
    Location:
    Washington, DC
    #2
    I had a similar problem, except my MacBook was the problem and this just started happening. The only thing that I had done differently to my MacBook before this was I turned on the OS X firewall as an experiment. So, I turned it back off, but still got the dreaded "self-assigned IP. I scoured forums all over the place (and found that most of the postings are three years old or more) and did essentially what you did. We don't have quite the same network configuration, but here's mine:

    All of my my wireless devices (iPhone, iPad, MacBook (white plastic one), iMac (3.6.GHz, Intel Core i5)) connect via AirPort to a Linksys E2000 router connected to a Westell DLS2 modem. After trying a dozen tricks, I turned off my MacBook, powered down my DSL modem and Linksys router for a couple of minutes, then powered them back on in reverse. It worked! I now have the same connectivity that I did before.

    I don't know if this will work for you, but I have my fingers crossed!
     
  3. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #3
    Make sure the DHCP scope on the Linksys has enough addresses to accommodate all your devices.

    If you are a proficient tech, I assume you have looked through the logs on both devices?
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Also the router that is closet to the modem should be the only device doing DHCP. If you are connecting to Extreme to Linksys then set the Extreme to "Bridged" mode. This way only the Linksys DHCP server will be the only DHCP server on your network..
     

Share This Page