Airport Extreme Internet Connection ( No DNS ... )

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Jmarsiglio, Aug 19, 2010.

  1. Jmarsiglio macrumors newbie

    Jun 2, 2009
    Hello, I was trying to change my IP today and decided to leave my modem unplugged for an hour. I went back, re-plugged everything back into it's place when I noticed the flashing amber light on my Airport Extreme and tells me Problem: Internet Connection. I'm writing this message by connecting my ethernet directly from my modem into the computer opposed to into the router.

    I attached screenshots and here they are as well if you prefer:

    Imageshack - picture1mnx.png
    Imageshack - picture2xy.png
    Imageshack - picture3pb.png
    Imageshack - picture4sg.png

    Thanks for any feedback it's much appreciated I don't know what to do :(

    Attached Files:

  2. JayMysterio macrumors 6502


    Apr 24, 2010
    Rock Ridge, California

    I'm having the same issues myself since yesterday. Any help would be appreciated. I spoke to my cable provider who reset my modem, and all the steps, with them realizing it was an issue with the IP address on the modem. Like yours the Airport has a 169. IP address while your mac shows a correct address. Supposedly the airport is registering the wrong IP address.

    The provider recommended calling Apple.

    Trying to put off that one hour ordeal myself.
  3. Jmarsiglio thread starter macrumors newbie

    Jun 2, 2009
    I can't get Apple to help me because my warranty on the computer expired and I don't feel like paying 40$+ for something like this. It seems so trivial, there has to be an easy solution :) Anyways, please tell me if you figure it out and anyone else if you have any feedback, it would be appreciated.
  4. naples98 macrumors member


    Sep 9, 2008
  5. Jmarsiglio thread starter macrumors newbie

    Jun 2, 2009
    Okay, after many,many hours today ( my day off ) I managed to figure it out by researching about 50+ forums with similar problems, so have no fear we are not the only ones :) What did it for me was ( no idea if all steps are required )

    1. Delete: Library\Preferences\SystemConfiguration folder.
    2. Unplug modem + Airport power cable.
    3. Unplug ethernet cable from Airport router.
    4. Restart Computer.
    5. Re-plug modem's power cable and wait until all lights go on.
    6. Re-plug the airport's power and then connect the two with ethernet cable.
    7. At this point my light was green but I still had no access to internet, so I went to TCP/IP under the Manual Aiport\Internet tab and deleted the DNS server that was in it (, switched to configure IPv4 to manual then back to DHCP and it fills in with whatever it should be ( my case was 64.xx... ).
    8. Updated base station and I am now sending this message via wireless internet :)

    Good luck and post if this works!
  6. JayMysterio macrumors 6502


    Apr 24, 2010
    Rock Ridge, California
    That's basic 101. If you talk to someone in support you inevitably turn off/on - restart your modem, your router, and your system. My cable company could see that I had a base station, and tailored their responses toward that, and were the ones that told me to call Apple after they got me up and running again.

    So yes, restarted multiple times, after the modem is restarted.

    I unfortunately don't seem to have a systemconfiguration folder, so not sure how that work around will fly. After I eat, charge my iPhone, I'll deal with Apple. I luckily just activated my Applecare, so should be good to go. :eek:
  7. Jmarsiglio thread starter macrumors newbie

    Jun 2, 2009
    Hmmm, that's too bad, wait until I get home and I will double check. Just look under Library > Preferences. Then I believe it is the last folder. In regards to apple support, good luck and don't forget to tell us how you solved the problem as it will help people with this problem in the future. Good night :)

    edit: Yep, it definitely is SystemConfiguration. Are you on leopard?
  8. Butthead macrumors 6502


    Jan 10, 2006
    Unless it's been deleted, you have it. I can't get Apple's Find command from the finder to locate system folders (even from Admin level acct).

    Click on your drive icon where the OS is installed, start from the top level "Library" folder, not "System" folder, which also has a Library/Preferences/SystemConfiguration folder full of .bundle files.

    see attached image.

    ^[edit: doesn't seem to be responding...waited 10min, I gave up]

    My guess is you'd only need to delete the from that sysconfig folder.

    I checked, it's in the same location back to 10.3...10.2 doesn't seem to have it, but there is an airport.adminutility.plist file in preferences under each users acct's. "Library" folder
  9. JayMysterio macrumors 6502


    Apr 24, 2010
    Rock Ridge, California
    I did follow the OP's direction, and I assure you that I don't have that folder. I don't recall deleting it at some point. I have no idea why, I also could not find it with finder.

    My solution was the most simple though, while restarting the modem & airport extreme over & over again accomplished nothing. I went with just completely resetting the airport. That did the trick, despite having to put my info in again.
  10. kcerce macrumors newbie

    Jan 25, 2010
    I have a similar problem. I unplugged my modem to take on vacation and left my Airport Extreme plugged in at home. When I returned, I plugged the modem back in and no internet access. The AE has a green light but when running network diagnostics, i get the first 3 lights green and the last 2 yellow. I have tried unplugging the modem, router and computer all night and powering them back up, waiting 15 min in between with no luck. I replaced the Airport Extreme with an airport express and now I have internet. My modem seems to work fine since it works when wired directly to my computer and when connected to my airport express. What could be wrong with my Airport extreme?

Share This Page