AirPort Extreme is slowing my internet speed

Discussion in 'Mac Accessories' started by mitch1211, Oct 24, 2013.

  1. mitch1211 macrumors newbie

    Joined:
    Feb 9, 2013
    #1
    Hi All,

    My network configuration is a D-Link DSL-502T second gen connected to Apple AirPort Extreme Base station.

    For a long time I had the D-Link doing the PPPoE internet connection (required by my ISP), DHCP and NAT. The Airport was simply operating as a wireless network in bridge mode. Call this configuration 1.

    Recently I've wanted to make use of back to my mac and other networking features using the Airport as the router. Port mapping etc is infinitely simpler on the Airport compared to the D-Link; I have tried port mapping on there to no avail.

    I changed the D-Link to be in full bridge mode only and then entered my PPPoE settings on the Airport so that an internet connection could be established. The airport is now handling the internet connection, DHCP and NAT. Call this configuration 2

    At first everything was running smoothly, then I noticed a drop in internet speed.

    In configuration 1: speed ~ 400kB/sec (typical of my internet connection)
    In configuration 2: speed ~220kB/sec

    Often in configuration 2 the speed would initially be close to the 400kB/sec mark however then would drop consistently to about 220kB/sec.

    It almost seems as if the Airport is throttling the speed to a consistent 220kB/sec...

    Has anyone else had similar issues or know a way around it? I've tried setting the D-Link in half-bridge mode so that it handles to PPPoE connection only and then the airport handles DHCP and NAT however I had no success connecting to the internet this way.

    Thanks!
     
  2. mitch1211 thread starter macrumors newbie

    Joined:
    Feb 9, 2013
    #2
    I think it could possibly be the D-Link freaking out in bridge mode. The ADSL transfer and LAN lights are flashing really quickly, faster than they normally would in configuration 1.

    If i turn the modem off and then back on I get the 400kB/sec speed briefly before it slows down again. If it is the D-Link, why would it be doing this?
     

Share This Page