airport extreme problem.

Discussion in 'Macintosh Computers' started by expergo, Jan 5, 2005.

  1. expergo macrumors regular

    Nov 21, 2004

    for the past while i've been connecting to my router via airport extreme on my ibookg4 that i got in november. all of a sudden dropped the connection and does not connect to it again. when i type in the ssid for the network, it says "there was an error joining network - alpha". i usually leave the broadcast ssid off on the router but tried it on and it still didn't detect it. when the ssid was on, i tried kismac and that detected the signal but the airport utlity at the menubar wouldn't connect to it.

    i have another pc laptop with a wireless card that connects fine to the network. i don't use encryption and it is a 802.11b network.

    i also deleted the airport.preferences...plist file and turned airport on again and it didnt' work.

    any help appreciated.
  2. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    Did you try to reset the router (even though the PC can join it)?
  3. expergo thread starter macrumors regular

    Nov 21, 2004

    i still have the same problem.

    everytime i wake my computer i have to turn off and on my airport to get the signal again...

Share This Page