Airport Extreme & Time Machine

Discussion in 'Mac Accessories' started by Jaw3000, Mar 22, 2008.

  1. Jaw3000 macrumors regular

    Joined:
    Jan 6, 2004
    #1
    As has been widely reported, the new Airport/Time Machine update released a few days ago supposidly finally enables Time Machine for AirDisks. Sure enough, my new AirDisk showed up in Time Machine, but after a successful 1st backup, I began experiencing a lot of problems. I'm using 10.5.2 and an Airport Extreme (gigabit) model.

    I did a successfull backup, which created a sparse image on the AirDisk. However, it was full of problems. First, when performing a backup when the AirDisk is available but not mounted, Time Machine doesn't mount the disk and instead reports the error "No backup volume selected." I can start a backup after mounting both the AirDisk and the Sparseimage, but this defeats the automatic nature of Time Machine. Further, when attempting to open Time Machine to browse my backup, I get the error "The storage location for Time Machine backups can't be found." This occurs both without the airdisk mounted and periodically when mounted. After numerous tries, I can sometimes get Time Machine to perform a backup, but Time Machine doesn't automatically unmount the sparsedisk after its finished. It has to be unmounted manually. Furthermore, Time Machine turns itself off after every system restart, and requires manual intervention to re-enable Time Machine for automatic backups (at least until the next restart).

    A few months ago, I had used the "defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1" hack and began to wonder whether these problems (and the fact that I can even select the AirDisk in Time Machine) could be attributed to it and not the new official support enabled by the update (I had never disabled the hack). So, just to see what would happen, I disabled the hack (which still seemed to be enabled). Afterwards, my AirDisk no longer appears as a drive in Time Machine.

    Has anyone experienced anything similar to this? Does any ideas how to get Time Machine to recognize my AirDisk, since the unsupported hack is no longer supposed to be needed and to fix the problems I've been having? Help would be greatly appreciated!

    By the way, can anyone successfully using Airport Extreme with Time Machine after the update check their defaults write "com.apple.systempreferences" file and see whether "TMShowUnsupportedNetworkVolumes" appears, and if so, what its value is? Thanks!
     
  2. Jaw3000 thread starter macrumors regular

    Joined:
    Jan 6, 2004
    #2
    More problems

    Here's an update: After a restart, I manually turned Time Machine back on (as I mentioned above), and an automatic update began. This time, the AirDisk and sparse image was automatically mounted. However, Time Machine began to back up again the entire 30GBs that it already backed up yesterday during its initial backup. Not many files have changed since the last backup, so the backup should be pretty small. All of my excluded files are still listed, so I don't think Time Machine is trying to back up new files.

    My whole experience with Time Machine has been nothing but trouble. First, I bought an external USB drive (now my AirTunes drive) to use with Time Machine directly via USB, and soon after the 10.5.2 update, my backup got corrupted (I believe by canceling a backup after it started) and each backup would end with errors. I tried to delete my backup from the disk, but the Finder reported it as taking two whole days to delete the 60+gb backup. This was ridiculous, so I obviously had to erase the partition and start over. Second, when Time Machine worked, it took forever. Not counting the initial backup (which took ridiculously long), Time Machine took 3-4 hours just to complete a regular hourly backup and the CPU usage on my PowerBook was tremendous. Finally, I get the idea to start over with an AirDisk after the recent Airport update, and now I have all of these problems. This is really the first piece of Apple software I've used that is really plagued with problems. Contrary to Apple's design principles, Time Machine just doesn't work, and this is really bad for a backup application!

    Any help would be greatly appreciated!
     

Share This Page