airport fails to connect

jlewis2k1

macrumors 6502a
Original poster
Jan 14, 2005
718
0
in your closet
Ok, so if i were to put my computer to sleep for like lets say an hour then i would to wake it up then i would have a problem connecting to a wireless base station. That is when I would have to manually turn off the airport and turn it back on before it connects to a base station. I went to apple's discussion forums and found a potential solution but it does not work for me. Anyone has any ideas to why this happens?

Recap:
When computer goes to sleep for an hour the Airport refuses to connect to a network unless it is forced to be turned off then turned back on.

Specs:
Intel Mac Mini 1.66 GHz Core Duo
512 MB Ram
80 GB Drive
10.4.8
 

jlewis2k1

macrumors 6502a
Original poster
Jan 14, 2005
718
0
in your closet
sorry for the late response but this is the solution i tried.

FIXED

Firstly, this definitely worked for me and allows me to use the preferred network options on WIFI. I think somehow the cache files get corrupted at some point. I did the following:

Click on Finder. Click on your house icon (for home). Click on Library. Click on Caches. Drag the contents, but not the Caches folder, to the bin.

Again, click on the Finder. Click on Library. Click on Caches. Drag the contents, but not the folder, to the bin.

Click on Finder. Click on your house icon (for home). Click on Preferences. Locate the files begining with com.apple.airport. and drag them to the bin.

Reboot and all should be well. If you're not using preferred networks you can now do so.

At the time of writing the 10.4.6 update has just been made available. So far, so good.

Disclaimer - this worked for me, but I cannot be held responsible if you damage any of the files, folders or configurations of your computer or laptop.

Hope this helps
 

mad jew

Moderator emeritus
Apr 3, 2004
32,191
5
Adelaide, Australia
Okay, go into System Preferences and hit the Network button. Once you've selected AirPort, and then select Preferred Networks from the drop down list associated with By Default, Join... In this list, remove your network(s), close System Preferences, open it again and come back to this location. Now, re-add your network(s) and see how that goes. This has worked in some cases so hopefully it'll help you too. :)
 

thewhitehart

macrumors 6502a
Jul 9, 2005
995
183
The town without George Bailey
All of a sudden, I started having this problem too. And I thought I fixed it by following the recommended steps of removing my preferred networks and readding them.

After waking from sleep, airport disconnects and assigns itself its own ip address. I have to manually shut off airport and turn it back on again.

My intel airport problems under 10.4.8 are driving me nuts! :mad:

This is the only problem I've ever had with a mac that has no apparent permanent solution.
 

r6girl

Administrator/Editor
Staff member
Sep 6, 2003
1,726
47
Massachusetts
fwiw, i was having these exact problems on my macbook. i thought it had something to do with the latest firmware/smc updates that apple put out, but it was actually coconut wifi. if you have coconut wifi installed, remove it! i no longer have any problems whatsoever reconnecting to my airport network automatically after sleep.

i'm afraid i don't have any suggestions if you don't have coconut wifi, though... :eek:
 

4np

macrumors 6502a
Feb 23, 2005
963
0
The Netherlands
I have posted the solution for this issue a couple of times on this forum. It is being caused by having multiple keychain entries for the same wireless network; it looks like the driver does not know which one to use or something. I think you probably reinstalled your access point? This is what caused this issue on my PowerBook and my girlfriend's iBook.

To fix this issue you have to remove the duplicate keychain entries by doing the following steps:

1. open keychain (Applications --> Utilities --> Keychain Access.app)
2. click on 'System' in the 'keychain' pane
3. locate the name of the wireless network in main pane; you probably have duplicate entries here
4. delete all entries for that wireless network (delete them all to be sure; if you don't know the password see my ps)
5. reconnect to the network and enter the key/password for your network

You will autoconnect again after awake from sleep :)

Good luck!

ps. if you do not know the password for your network you can (double) click each of the duplicate entries and check the 'show password' checkbox.
 

roland.g

Suspended
Apr 11, 2005
6,778
1,992
I have posted the solution for this issue a couple of times on this forum. It is being caused by having multiple keychain entries for the same wireless network. I think you probably reinstalled your access point?

To fix this issue do the following:

1. open keychain (Applications --> Utilities --> Keychain Access.app)
2. click on 'System' in the 'keychain' pane
3. locate the name of the wireless network in main pane; you probably have duplicate entries here
4. delete all entries for that wireless network
5. reconnect to the network and enter the key/password for your network

You will autoconnect again after awake from sleep :)

Good luck!

ps. if you do not know the password for your network you can (double) click each of the duplicate entries and check the 'show password' checkbox.
I have had a similar problem as the OP. My airport usually works but every other day or so when I wake it (and the hard drive never goes to sleep, only the display), the airport fan is gray. I don't have to turn the airport on and off, just reselect my network from the list. I have tried resolving the issue with Applecare, dumping my plist files, even took it to the genuis bar, and they have no idea. it is very intermittent. I have set it as my only and preferred network and 80% of the time it works. But once or twice a week I will wake it, go to a site, safari can't display and I look over and my airport fan is gray. It is on a 1.66 Core Duo refurb Mini. For what is it worth I will try the keychain solution when I get home, but I don't think that will solve it. I've had the Mini a month now.
 

thewhitehart

macrumors 6502a
Jul 9, 2005
995
183
The town without George Bailey
My airport is going absolutely bonkers today. Has anyone with airport problems under 10.4.8 found a permanent fix yet? Apple's suggestion of removing and re-adding WPA2 networks to the preference list is useless. Here's the lowdown, as quoted from me on Apple's support forum thread regarding this issue. I have posted my thread replies here to highlight my particular circumstances.

thewhitehartI think this is embarrassing that Apple has not solved this issue yet. With so many intel mac users having problems, it makes me think that Apple refuses to acknowledge a faulty chipset with the airport cards in the early intel Core Duo iMac models. As far as I'm concerned, a fix should be out for this ASAP - it is a serious problem that seems to occur almost randomly.

I have exhausted numerous methods to correct this issue - following Apple's instructions precisely to delete and re-add WPA2 networks. I have tried it from both administrator and standard accounts, applying the change, and quitting System Preferences before turning on Airport. I have tried the so called fix with airport on and off, I have tried hard resetting the mac after re-adding the WPA2 networks, I have tried 'Automatic' and 'Preferred Networks' settings, I have tried adding only one WPA2 network and adding many - I have tried every method possible will an exhaustive list of variables without resorting to the Terminal and UNIX, which I am not skilled enough to do. The problem has occurred only after the 10.4.8 update, and even after the firmware updates and the 10.4.8 security fix. After following Apple's recommended fix and then shutting down the computer, the iMac often freezes and power needs to be cut from it. Using a G4 ibook as a control group has narrowed it down to an intel only problem, but I suppose Apple already knows that - so why aren't they fixing it?

Airport won't connect after startup or after sleeping. I can't seem to pinpoint the steps I've taken that have actually affected a successful reconnection to my router. It seems to be totally random when airport finally decides to stay connected. I've tried resetting the router too, which is an airport express, but it didn't help. Nor did checking the box under 'Options...' that tells airport to disconnect after I log out. While logged in, airport will suddenly lose connection, and will drop and reconnect to my preferred network several times. It never successfully receives an IP address from the router, though, and ends up assigning itself an IP address. Once in a while, it cannot find my network at all, and all attempts to shut airport on and off to see if the network reappears resulted in failure. The airport express light is green and running at all times, as my G4 ibook can successfully hold a connection. As for the poster who asked about my signal, yes; it does drop to one bar and becomes very slow on occasion. I have ruled out interference from other radio sources and it seems to be tied to the existing airport problem.

I am now connected to my router and receiving an IP address from it, but it may lose connection at any time. The circumstances at which it is connected now are the same as the circumstances as when the connection problems occur as far as I can tell. It's driving me nuts - not only am I unable to pinpoint the cause of the disconnections, but I am unable to identify the exact solution to keeping it connected. It seems to have a mind of its own.
 

ascender

macrumors 68040
Dec 8, 2005
3,310
1,242
There's quite a few workarounds and possible solutions over at the Apple support forums. In the end i just bought a cheap wireless bridge and turned the airport off. Kind of pointless I know, but the connection is now extremely fast and reliable.
 

JenSee

macrumors newbie
Aug 21, 2007
1
0
". . . go into System Preferences and hit the Network button" etc

Thank you thankyou thanku, Mad Jew.

Problem solved @ last, and I never even knew that selection was available.

Peace at last.

Ta!

(p.s. My probs were with working to a third party wifi router, so the prob was all in my Mac's preference setting.)

(p.p.s. Now I'm off to find your cousin, the one who knows how to restore volume & partition icons to the desktop! And no, it isn't the obvious Finder Preference - but then, I wonder where that file lurks? Hmmm . . .)
 

mad jew

Moderator emeritus
Apr 3, 2004
32,191
5
Adelaide, Australia
No worries mate. You might be after com.apple.desktop.plist or com.apple.finder.plist. However I'm not 100% sure I know what the problem is so can't really go further 'til you tell us more details. :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.