Airport has self assigned IP address when connected to Czee wifi point.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by iWilson, Sep 23, 2009.

  1. iWilson macrumors newbie

    Joined:
    Apr 5, 2009
    #1
    I'm on a military base, which has Czee wifi. Czee is a pay as you go wifi connection, much like the ones at airports. I am able to connect to it, but when I try to open a page in safari, it says I am not connected to the Internet, it does not bring up the page to pay for the service. When I use the diagnostic to see what the problem is, it says Airport has a self-assigned IP address and may not be able to connect to the Internet. Any idea what the problem is and how I can fix it?
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #2
    It sounds like you either haven't associated with an access point or are failing to retrieve a DHCP address. Do you have any control over the access point (i.e. can you reboot it)?
     
  3. iWilson thread starter macrumors newbie

    Joined:
    Apr 5, 2009
    #3
    No access to control. I do know that other people aren't having any trouble accessing the service on their laptops.
     
  4. springerj macrumors member

    Joined:
    Jan 29, 2004
    Location:
    Portland, OR
    #4
    some ideas

    My suggestions:
    First, clear out the old network settings for this wap from the mac. Go to the network control panel (system preferences) and make sure you are set to location: automatic. Then click on Advanced and the Airport tab. Select the network your trying to connect to, and hit the "-" button below the list to remove it from the remembered settings. Click the TCP/IP tab and make sure it's set to DHCP. Click OK and close the panel. Then Log out (under apple menu) and log back in. It should not automatically connect to the router; it should ask you or make you choose it - a fresh start. That will often fix a wireless connecton problem.

    If that doesn't work, open the network control panel and click on TCP/IP and cLick "Renew DHCP Lease" and see what happens. If your IP addresses starts 169.x.x.x, you are not getting an IP address from the router. You might try doing a restart at this point. That process has alway solved DHCP problems for me.
     
  5. iWilson thread starter macrumors newbie

    Joined:
    Apr 5, 2009
    #5
    No dice. Neither of those options worked. Any other ideas?
     
  6. springerj macrumors member

    Joined:
    Jan 29, 2004
    Location:
    Portland, OR
    #6
    still no ip?

    You're still getting a message about "no connection to internet"? Is your IP address somthing starting 169.? You won't be able to do anything until you get a valid IP address. I assume you can connect to other access points fine?

    Hmm. The only other thing I can think of is to try to set up a fixed IP address, which is a bit complex, and it might not work depending on how the security system works.

    Sorry.
     
  7. tom.96 macrumors regular

    Joined:
    Jun 13, 2003
    Location:
    UK (southern)
    #7
    Me too!

    Hi

    I'm having exactly the same problem. Since upgrading to SL I get the same message 'AirPort has the self-assigned IP address and will not be able to connect to the Internet.'

    I used to be able to go in to coffee shops and connect to the Cloud - but now I can't even see other networks in the list, it is empty but I know there is a network out there.

    It is really frustrating, having to spend loads on coffee whilst I try and work out what is happening. If anyone out there has any ideas I would be most appreciative of your help! (My ethernet broadband cable connection is fine)
     
  8. tom.96 macrumors regular

    Joined:
    Jun 13, 2003
    Location:
    UK (southern)
    #8
    go to system preferences->sharing and then untick internet sharing.

    It worked for me!

    Tom
     
  9. nooaah macrumors 68000

    nooaah

    Joined:
    Sep 3, 2009
    Location:
    Philadelphia, PA
    #9
    I just wanted to bump this because this completely solved at least an hour of aggravation. Thanks!
     

Share This Page