airport help

Discussion in 'Mac Basics and Help' started by pokmiuhy, Mar 12, 2008.

  1. pokmiuhy macrumors newbie

    Joined:
    Feb 17, 2008
    #1
    so i'm new to mac, and just recently received my new mbp. i love it. one of the best purchases i've ever made. along with the mbp, i got an airport. and that's where my problems begin.

    i've got a dell and the mac. i have my printer and my harddrive plugged into the airport. i can print wirelessly from both computers, but i can only access the harddrive from the mac. i was able to access it from the dell, but it no longer works. and i don't know why it just stopped. but it did.

    so now i'm in the process of trying to figure out why it won't work. and on top of that, i can't figure out how to connect the computers together for file sharing directly. i'd also like to change to a different workgroup just so that it's not the standard "workgroup"

    any help would be great. thanks in advance.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    First of all, the hard drive issue: Did you change any settings related to disk sharing on the AirPort recently? Make sure that Windows disk sharing is enabled on the AirPort - this is required to get the Dell to see the disk.

    Second - regarding file sharing, are your computers on the same Windows workgroup? (I'll explain how to check and change this in a moment.) Also, is file sharing enabled on both sides, and are the accounts to use it with enabled on the Mac?

    Finally, regarding the workgroup setting: To change the workgroup on the Mac in Tiger or earlier, open up Directory Access in Utilities, click SMB, and type in the new workgroup name. I don't know where Apple put the Windows workgroup setting in Leopard, but I suspect it's in System Preferences somewhere.
    As for Windows, if you're using Windows XP you change it by running the Network Setup Wizard, which is found in Network Connections (it might be in your Start Menu).
     
  3. pokmiuhy thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #3
    I've enabled disk sharing on the AirPort. I don't know if i've enabled windows disk sharing on it though...how would i do this? On my dell, it's showing that there is a disk, but it gives me a file path error. I will have to go back and make sure all the permissions are there.

    I only have one account on both computers and have the quest account disabled on both computers. I had set the windows workgroup to, for example, XYZ. I also changed the AirPort settings to XYZ for the workgroup of the harddrive, but I didn't change my mac to the XYZ workgroup. I just realized this, and I'm trying to figure out how to do it.

    So once i change the workgroup in windows and in leopard then they should be able to see each other. then it's just a matter of permissions for them to be able to access each other? Do i have to do something in windows to allow my mac to access the dell?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    One small issue that can cause problems: Make sure both accounts have the same short user name, long user name, and password. If they don't, you can still share files but it'll refuse to save your credentials, and you'll have to log in each time, even if you tell it to save them. Also, in Leopard's Sharing preferences, make sure SMB is checked in the Options dialog, inside the Accounts... dialog, for each account you are using Windows Sharing with, on the Mac. On Windows, you need only enable Fire Sharing, make sure you have at least one folder shared, and set the sharing permissions correctly.
     
  5. pokmiuhy thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #5
    the passwords are the same and the usernames are the same. i just enabled smb(what does that mean by the way?)

    now i just have to change the windows permissions and share the folder. hopefully this fixes it. i've got all the workgroups the same. so i think that i should only see my dell from the mac, and not all my roommates.

    on the windows machine, do i need to create connections or anything?
    shouldn't it just be under network connections and in the "view workgroup" link?
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    SMB = Server Message Block, the protocol Microsoft uses for file sharing on Windows. As for your other question, you don't need to create any connections on Windows - it should work without them.
     
  7. pokmiuhy thread starter macrumors newbie

    Joined:
    Feb 17, 2008
    #7
    ok...thanks for the help...i'll post up the results, or more questions.

    thanks though
     

Share This Page