AirPort Internet Troubles - Please Help!

Discussion in 'Mac Basics and Help' started by ChantalMacApple, Jan 11, 2017.

  1. ChantalMacApple macrumors newbie


    Jan 11, 2017
    Hi! I just got a refurbished late 2007 black MacBook (2 GB memory running on Snow Leopard), mostly on the advice I found in this forum when I was researching on what to use until I can afford to have my dead MacBook Pro (2012) repaired.

    It seems to be in perfect condition, but I cannot access the Internet even though it says I am connected to my Wi-Fi. I know there is something I must do with the Network settings, but after looking for answers for the past several hours and becoming more confused, I need help. Can anyone familiar with the older software and this MacBook please help?

    I was able to get onto the Internet once but only to one page.

    Any help is much appreciated!
  2. keysofanxiety macrumors G3


    Nov 23, 2011
    Try change the wireless encryption on your router to WPA2-PSK only (no mixed mode). WPA2-PSK may also be called WPA2-AES. If you need help with this, please advise what make your router is, or which Internet provider you're with.

    You can also click the Wi-Fi icon on the top menu bar and select 'Open Network Preferences' at the bottom. At the top, you'll have Location. Click this drop-down box and select 'Edit Locations'. Then click the Plus (+) icon and add a new location. See if that works.

    If that doesn't work, can I check if you set it up from new? Or was it already set up with a user account? If it was already set up, you can try to create a new user account through Apple menu> System Preferences> Users & Groups, then click the padlock at the bottom-left to unlock. Click the plus icon under Login options to create a new user and ensure it's set up as an Administrator, then login to that one and see if that works.

    A few of these instructions might be slightly incorrect or have different wording as you're on a much older operating system, so just let me know if you get stuck at any point and I'll try be a little more helpful with screenshots/wording.

    Best wishes & speak with you soon.
  3. ChantalMacApple thread starter macrumors newbie


    Jan 11, 2017
    My router is Motorola & I have AT&T U-Verse.

    Where would I find the WiFi icon?

    I set it up as new & am the Administrator.
  4. keysofanxiety macrumors G3


    Nov 23, 2011
    Sorry for the confusion – the Wi-Fi icon will read as 'AirPort' on your laptop. Apple later renamed AirPort to Wi-Fi to avoid confusion. It'll look similar to this, and will be visible on your top menu bar: Screen Shot 2017-01-11 at 19.50.25.png

    Just allow me a few minutes and I'll get back to you about the router settings.
  5. ChantalMacApple thread starter macrumors newbie


    Jan 11, 2017
    Got it! Thank you! Please take your time as I am about to leave school (I teach) to pick my son up from his school. I appreciate your help!
  6. keysofanxiety macrumors G3


    Nov 23, 2011
    Let's go through the basics first: restart your router. Take out the power cable, leave it for 1 minute, and plug the power cable back in. Try to reconnect wirelessly. Any luck?

    If not, we'll have to roll up the sleeves and change the wireless encryption. Going on online instructions for your router, this should hopefully do the trick:

    1) Ensure you're connected to your router
    2) In the top address bar on Safari, type in and press Enter on your keyboard
    3) If it prompts you for a username/password, type in admin/admin or admin/password (hopefully one of the two will work)
    4) If neither of the above two password combinations work, check your router. You may have a label on there which reads 'System Password' or 'Device Access Code'. These are the details (username/password) you'll need to access the router.

    Once you've accessed your router (hopefully you have), this is where things get a little tricky. There's no generic layout for routers and I can't find documentation for your specific router, so you'll have to do a bit of digging around in the menus.

    What you'll be looking for are the wireless settings on the router itself. So keep an eye out in the router settings for anything that says 'WLAN', 'Wireless', or 'Wi-Fi'. If not, have a look for 'WPS', or 'WEP'. These are normally buried in Advanced settings, so if there's an advanced view that you can see, be sure to select it.

    Somewhere in there, you'll be able to select your wireless encryption. You'll know you're on the right lines if you see things listed like WPA, WPA Auto, WPA2, WEP. You want to change the settings to WPA2-AES only. WPA2-AES or WPA2-PSK. No mixed mode. Then apply any changes you've made and try to reconnect.
  7. ChantalMacApple thread starter macrumors newbie


    Jan 11, 2017
    Thanks - I will try this when I am back home in about an hour.
  8. ChantalMacApple thread starter macrumors newbie


    Jan 11, 2017
    This still did not work.

    Is there a System Preferences Ethernet issue possibility?
  9. kiwipeso1 Suspended


    Sep 17, 2001
    Wellington, New Zealand
    Ethernet is wired internet, it is very rare to have problems with it.
    I suggest that as long as your router is set to DHCP on the LAN settings, you should be fine.
  10. kschendel macrumors 6502a

    Dec 9, 2014
    What are your current network settings? and can you see the router if you use a wired connection to it? (ie can you access as mentioned above? or perhaps

    There's a bit of a chicken and egg here. You need to configure the router appropriately, but you can't do that unless you can connect to it, and you can't connect if it's not configured right. The way out is to use a wired connection to the router, even if temporarily, and use that to configure it for wireless the way you want. (Apologies if this is already clear to you.)
  11. Fishrrman macrumors G5


    Feb 20, 2009
    Just wondering, what is wrong with the MacBook Pro?

Share This Page