Airport Keeps Going In & Out

Discussion in 'MacBook Pro' started by Phenobarbital4U, Sep 26, 2008.

  1. Phenobarbital4U macrumors newbie

    Jul 27, 2008
    Hey so I have had my MBP for about 4 months now and I have just recently been having these problems with my Airport.

    Ill be surfing the web, or chatting on iChat/Skype and every two mins I will lose my connection. Or when I'm surfing the web, it is fine one second, then another second when i try to click a link it will stay on the loading page for 2 mins then go to the error page. It will just keep going in and out. :mad:

    I have tested it and ruled out any issues with my wireless connection in my house. I went to other houses and still had the issue. Also I had someone else with a laptop use it in my house, sitting right next to me, and theirs would be working fine while my connections was bad. :confused:

    It is something that happens from once every two days, too happening constantly throughout a days usage. For me its very frustrating to be surfing the web or talking to a friend and having to restart the application or turn my airport on and off because of a lost connection.

    If there is some trick I could do, or something I haven't set right please let me know. :(

    Thanks for the help guys
  2. techound1 macrumors 68000


    Mar 3, 2006
    Try resetting the SMC.

    The System Management Controller is an integrated circuit (computer chip) that is on the logic board of the computer. As the name implies, it is responsible for power management of the computer. Over time, the settings in the System Management Controller may become unusable, which can result in operational anomalies with the computer.

    I'm wondering if it's maybe cutting power to the AP intermittently - resetting the SMC may help (and hey, it's free to try!).
  3. jhamerphoto macrumors regular

    Oct 26, 2007
    What kind of WiFi router are you using? If it's WEP encrypted, that's your problem. Macs don't really agree with WEP encryption on wireless internet, and prefer WPA.

Share This Page