Airport + Linksys problem on my iMac 2.4GHz

Discussion in 'iMac' started by Maxintech, Dec 19, 2007.

  1. Maxintech macrumors regular

    Maxintech

    Joined:
    Nov 8, 2007
    Location:
    Buenos Aires, Argentina
    #1
    People:

    Sorry for my English.

    I've bought the new Alu 24" 2.4GHz iMac and it's look fantastic and almost works great, but I've a problem setting the wifi connection with my router linksys WRT54GS (Firmware Version: v4.71.1, Hyperwrt 2.1b1 + Thibor15c).

    I've use the router like a DHCP server for the iMac, my notebook DELL and my old PC. Also servers like a DHCP server and i've assigned IP address for my PC MAC ADDR, for wifi notebook, ethernet iMac and wifi iMac. 192.168.1.101, 192.168.1.102, 192.168.1.103, 192.168.1.104 respectively.

    The notebook detects my wifi network and take the IP assign by the router and works fine.

    My iMac's AirPort detects my wifi network and takes a self-assigned IP (169.254.6.240). If I detached the ethernet cable, internet works bad.

    In the device's list from the router, I see the iMac wifi MAC ADDR assigned to the 192.168.1.104 with a "good" RSSI -44 dBm, but, I I look into Airport setting, the IP is self-assigned or has not IP at all.

    Any kind of advice.

    P.D.: Some parameters from my router

    Wireless Mode: Access Point
    Wireless Network Mode: Mixed (G/B)
    Wireless Channel: 11 -2.462 GHz
    Wireless SSID Broadcast: Enabled
    Security Mode: WPA2 Personal
    WPA Algorithms: TKIP+AES
    WPA Shared Key: xxxxxx


    Thanks in advance.
     

    Attached Files:

  2. Fritter1 macrumors newbie

    Joined:
    Aug 2, 2008
    #2
    iPhone WPA2

    Hi did you resolve your problem?

    I have a simular problem! same router version etc, I can't get my iPhone to connect to my wireless router.

    Any ideas
     

Share This Page