AirPort/ Macbook- Self Assigned IP address Displayed

Discussion in 'MacBook Pro' started by 700-Grizz, Mar 2, 2012.

  1. 700-Grizz, Mar 2, 2012
    Last edited: Mar 2, 2012

    700-Grizz macrumors 6502

    Joined:
    Sep 9, 2010
    Location:
    ALASKA
    #1
    :mad: Ok here goes--I have a macbook, connecting to my Airport extreme router that has been running fine, it has the latest Lion installed and as off last night it would not connect to my rounter. I have searched and found discussions and tried stuff to no Avail, Im hoping this new Thread will shed some Updated FIX for many of us, I hope!!

    The message I get is :
    *airport has a self assigned IP address and will not be able to connect to the internet* under my wireless connection--preferances/Network ect....
    My 'self-assigned' IP address, is in theform 169.254.xxx.xxx which is not mine and I cannot get rid of it even with I try and RENEW my lease?

    ***My other wireless items (MacPro/Ipad 1&2/ Iphones all connect fine to my router****

    So I know its a issue with this computer and I have tried everything I know to fix this.
    *Deleting all connection networks
    *Restarting rounter/Macbook numerous times
    *Firewall is OFF
    *Deleted my com.apple.airport.preferences.plist found in /Library/Preferences/SystemConfiguration

    Other things I cannot think of lol--I was up for hours last night:confused::confused:
     
  2. 700-Grizz thread starter macrumors 6502

    Joined:
    Sep 9, 2010
    Location:
    ALASKA
  3. IngerMan macrumors 6502a

    IngerMan

    Joined:
    Feb 21, 2011
    Location:
    Michigan
    #3
    I don't know, but I have heard of blue tooth interfering. Do you have it on the MBP? Try with it off, other than that some one else will help, I am sure of it.
     
  4. LCmarigold macrumors newbie

    Joined:
    Mar 2, 2012
    #4
    I've been having the same issue with my macbook.. only difference is i'm not on lion.

    I've tried everything from changing my router to getting one of my internet service providers to remotely access my computer to see if they can fix the issue... Its been going on for months. I've renewed the dchp licence, etc.
    All of my roommates have PCs and their laptops connect to the wireless no problem.

    Recently my wireless worked for a few weeks and then yesterday it stopped working again.. I'm still getting errors like connection timeout or invalid password (even though I've entered the correct password).

    This time around in my network preferences its no longer automatically connecting to the 169.xxx.xxx... IP address. So I'm not sure how much that has to do with the issue.

    I know this isn't much help, but you are definitely not the only one with this issue, so hopefully we can find a solution asap.
     
  5. Rory 7 macrumors newbie

    Joined:
    Mar 8, 2012
    #5
    This is exactly the problem I've been having for over a week.

    I've tried everything - an airport that had been working perfectly for over two years with an iMac, iPad, two iPhones, MacBook Air, MacBook Pro and PS3 now is reporting 'self assigned IP'....

    I'm at my wits end, can't get this fixed. Please help.
     
  6. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #6
    happens to me periodically.

    have you tried rebooting the cable box (or whatever) and the AX?
    turning off wifi, then turning it back on?

    these things usually work for me...

    you could also try changing channels on the AX.
    i use wifi scanner (app store) to check the networks my mac sees (a lot, am in ny), and i set my wifi for the least-used channel...
     

Share This Page