Airport : No Wan Ethernet Detected - TC cannot see cable modem

Discussion in 'Mac Accessories' started by Palad1, Dec 29, 2009.

  1. Palad1 macrumors 6502a

    Palad1

    Joined:
    Feb 24, 2004
    Location:
    London, UK
    #1
    Hello MacRumors, long time no see...

    I've got an issue with my TC setup, I cannot for the life of me get it to see the cable modem and setup the WAN access...

    If you will pardon me I will cutnpastize the lengthy description I left on the apple support list as I feel it is pretty thorough. I think I know my way around networks and dhcp but this setup doesn't yield any logs so I can't troubleshoot!

    --


    I'm on Virgin Media 20megs and I can't connect using my brand new TC.

    Modem: Ambit 256
    Time capsule : 1 tB, firmware 7.5

    Test router : Netgear WGR614V9
    MBP alubook 15 inch late 2008

    I tried connecting with the test router and the MBP alubook to the modem and both can pickup the ethernet connection and get a DHCP lease after some coaxing (cold-start the modem first, then cold-start the router/mbp)

    But I'm having no luck with the airport extreme base station. Hard reset / factory reset / soft reset, any startup order, nothing works. I even left the devices offline for an hour before doing another round of testing.

    I tried several cables (including a crossover cable) and all configurations work apart from the ones involving the time capsule.

    Both the modem AND the TC ethernet ports light-up with a green light... but somehow the TC doesn't negociate its DHCP or even basic ethernet connectivity.

    I see there's a firmware 7.4.2 on the support site for the TC but I'd rather not downgrade the unit.

    Here are the console logs from the MBP when it connects to the modem (yes, my MBP is named awesome, because frankly it is) :

    Any hints appreciated (gonna try setting up the MBP as a DHCP server and test the TC WAN ethernet port by connecting it to the MBP)

    After having spent 4 hours on this laborious process, I'm really at wit's end; any help would be greatly appreciated.

    Cheers,
    Palad1
     
  2. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #2
    As a test, you can probably connect the WAN port of the time capsule to one of the ethernet ports on your Netgear router to see if it works with the router (it should get an ip address via DHCP). That would help determine if it is a problem with the modem or the time capsule. If it does get an ip address with that configuration, then unplug the modem and leave it off for at least 1 hour before hooking it back up and connecting the time capsule to it.
     
  3. Palad1 thread starter macrumors 6502a

    Palad1

    Joined:
    Feb 24, 2004
    Location:
    London, UK
    #3
    Very good idea, thanks!

    Some progress: I've setup the TC for internet connection sharing with a DHCP request on the WAN port (ie standard cable modem settings) and hooked it up to my router -> no dice, same error message.

    Then, I switched the TC Internet>Connection Sharing to 'Off - bridged' and miracle, I see the TC MAC address sending out DHCP requests on my router logs and it even got its own IP now!

    So the WAN port is working, but there has to be a problem with the internet connection sharing setting. It's a bit crazy to see that the TC cannot do a dhcp request in this mode, but can in the bridged mode!

    So, to recap:
    - ICS off / bridged against netgear router works
    - ICS on / sharing against netgear router does not work
    - ICS on / sharing against cable modem does not work

    I see a pattern emerging here :)

    I am very tempted to downgrade the firmware... hope this will not break my warranty.

    I'm starting to regret buying networking gear from Apple now. That's not the kind of buyer's remorse I'm used to from Apple products.
     

Share This Page