airport not always connecting to preferred network

Discussion in 'MacBook Air' started by islandsnow, Apr 10, 2008.

  1. islandsnow macrumors member

    Joined:
    Feb 14, 2008
    #1
    hello. i have a macbook air, but this seems to apply to any mac's with airport. i connect once to our corporate wireless network, i type in the password and it connects. on occassions, when i start up the computer, it doesn't connect and a window pops up with my network listed but it says "none of your preferred networks are available"

    when i first connect i do check off remember this network. so why isn't it remembering it? seems airport is always flakey.

    when i go into system preference and click on network, select airport andc click on advanced, that network does appear under the preferred networks. does anyone know why its not letting me automatically connect the next time? sometimes its ok, sometimes it doesn't even know i connected to this network before.
     
  2. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #2
    I'm experiencing the same problem on my MBA. It usually works out that if you just leave the computer for a second, the box will disappear and connect on its own, but this isn't always the case.
     
  3. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #3
    You should try to set up different locations for 'home' and 'work' and not just have it on 'automatic'. On the list of networks it will only join the one wireless one on the list (this is on Tiger, might look a little different on Leopard).

    [​IMG]
     
  4. islandsnow thread starter macrumors member

    Joined:
    Feb 14, 2008
    #4
    ok thanks, i will try to set up different locations and see if that helps. the thing is, if i keep trying and trying and trying, it eventually connects. or if i ignore it for a bit, then it finally connects eventually. does it have anything to do with signal strength maybe? but its almost at full bars...
     
  5. Golden Master macrumors member

    Joined:
    Jul 7, 2007
    #5
    I'll be very interested to hear how you get on as I am having similar problems. In my case I can connect at work (to an open network) but at home I get the 'none of my preferred networks is available' message (even though my pref network is listed in my preferences and is being broadcast). When I select my network and enter the WPA-PSK password, I get a connection timeout message.

    The problems occur if I'm in a different room to the router (even though my MBP connects just fine from anywhere in the house). If I try many times I'll often get on. Importantly, if I move to the same room as the router, I tend to just pick up the network automatically (suggesting there is not a fundamental problem with the security). It's weird and I'm 'under' applecare for it at the moment as I'm hardly living the wireless MBA dream currently.

    Lots of things have been tried:
    Changing the channel
    switching from b/g to g
    disabling security
    Updating the router firmware (Netgear DG834PN BTW)
    Setting up new user account on the MBA
    Deleting key chain entries
    re-entering the network manually in prefs

    Who knows..
     
  6. JSweeny macrumors newbie

    Joined:
    Apr 25, 2008
    #6
    Fix: Leopard forgets preferred networks

    I have been searching high and low for a fix to this and none have worked…until now!

    I spotted a fix to this problem that strangely centered on the specific location of the “System Preferences.app”, if other than the standard location of the root of the “Applications” folder. I had in fact moved mine and would NEVER have thought it related to this bug. Hmmm!

    If you have moved the System Preferences application (not alias, actual app) to any other location for any reason, your newly joined preferred network will NOT be properly remembered and will NEVER be properly rejoined. Apparently one of the multi-step system procedures involved in properly saving a preferred network assumes the location of System Preferences to be the standard location. Period.

    FIX:
    1) Move “System Preferences.app” back to “Applications\”.
    2) Delete all instances of “Preferred Networks” in “Network Preferences”.
    3) Delete all “Airport network password” instances in “Keychain Access”.
    4) Restart your Mac.
    5) Add/Join applicable preferred network using the Airport pulldown menu or in Network Preferences (as if for the first time). Use “Advanced” in “Network Preferences” to confirm the existence of your preferred network and the correct settings. Use “Keychain Access” to confirm the existence of the applicable “Airport network password” instance and the correct settings.
    6) Restart your Mac. The OS should now find your preferred network and join it on its own. Good Luck!

    NOTE: Simply moving back System Preferences will NOT suffice. Deleting and re-adding/joining the preferred network is a must after the app has been moved.
     
  7. Johman macrumors newbie

    Joined:
    Apr 28, 2008
    #7
    Airport

    Hi

    I normally just turn Airport on my Mac on and off and it works fine again.

    Sometimes, if you're not using an Airport base station, the wireless router does not give the correct IP address hence, though you're connected, you're Mac doesn't work. To repair this, try connecting to Network Preferences and click the RENEW DHCP LEASE to obtain a new IP setting.

    The easiest is still the first option above.

    Hope this helps...

    Johman
     
  8. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #8
    Mine has had this happen a few times also but I turn airport off then on again and all is well.
     
  9. JuniorBurger macrumors newbie

    Joined:
    Aug 4, 2008
    #9
    Oh my God I am going to smash this mac...

    Geeze... I thought getting a PC wireless connection was a pain in the bum, but I hadn't experienced the delight of battling a Mac MBP wireless connection. It is seriously broken. Seriously.

    I think I have experienced most of the issues under the "none of your preferred networks are available" umbrella, and still can not get it to work properly. I still have to manually click the AirPort icon in teh top right of the screen, and drop down and click the network I have set up. Sometimes it works, sometimes it times out. Its possible that there is something else wrong. But, I have two other PCs on the same network that work flawlessly (I am doing this entry on a Dell...).

    All I really want is the stupid mac to remember the network that I have setup, and connect automatically at startup. I've tried everything, but nothing works for me. I'm almost ready to try and fit this thing up the behind of the fella that sold it to me.

    If there is anyone with any advice, my ears are open wide. Thanks in advance.
     
  10. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #10
    I had problems similar to this and finally resolved them by simply adding an Airport Express in the same room where two of my computers are (the router and modem being in another room). I think that my main problem was due to the fact that I'm in a condominium and most of the other people in this building also have wireless setups. I tried changing the channel first, thinking that would help, but it wasn't enough. I suspect what was happening was that there were just too many other wireless connections and conflicts going on every time any of my computers tried to connect to my wireless network. I needed a really strong force (connection) to overcome those. Things seem to be working smoothly now.
     
  11. gabssnake macrumors newbie

    Joined:
    Nov 29, 2007
    #11
    Yet to find a solution

    I have the same problem, my preferred network not being automatically joined.

    I'm having this problem since I updated to Leopard, maybe a few weeks later. I never experienced this before with Tiger, same router and settings.
    I did have Systems Preferences.app moved to another folder, so I corrected this and followed the steps described. I also tried to set up a new location.

    None of these seem to work yet. So I'm still in the thing.


    --------
    White MacBook 2GHz Intel Core 2 Duo - Mac OS X 10.5.5 Leopard - With all recent updates - Lynksys Router with WEP encryption
     
  12. edatrb macrumors newbie

    Joined:
    Feb 24, 2009
    #12
    Modified Fix

    This happened to me after I moved my System Preference to the Utility folder. JSweeny solution is the best solution, but I didn't want to recreate all of my 15 wireless networks and passwords at the same time, since I'm sure I would have messed up with typos.

    1) Drag System Preferences back to the Application folder in finder
    2) Use spotlight to find Keychain Access
    3) Delete the password of your problematic AirPort network
    4) Reboot
    5) Join the network and enter your keys.

    But if you don't have a lot of networks, just redo them all now and save your self the trouble later.
     
  13. JSweeny macrumors newbie

    Joined:
    Apr 25, 2008
    #13
    RE: Yet to find a solution

    Dear "gabssnake" and others,

    My "fix" addresses a very specific problem - having moved the "System Preferences" app. Wireless connectivity remains a very complex technological process that is directly affected by several factors including hardware, software, the OS and the physical environment the connection is taking place in.

    I continue to have occasional problems re-connecting/re-joining preferred networks because of any one of those factors mentioned. None of the connection problems have been permanent and all have been resolved with the appropriate troubleshooting. That said, you will NEVER properly re-connect/re-join your preferred networks if you have moved your "System Preferences" app. You would be wise to eliminate that additional factor if it in fact applies to you.

    If you have never moved your "System Preferences" app, then my "fix" is not for you. Good luck finding the one that works best for you!
     
  14. rastogim macrumors newbie

    Joined:
    Jan 15, 2008
    #14
    I realized after struggling for awhile, that within the advanced window you have to hit ok. After that closes you need to hit apply. Otherwise none of the changes you made to the preferred networks (i.e. deleting networks or changing the order) stays. Seems that after you hit ok, it should apply the changes, but i guess not. Very frustrating.

    -M
     
  15. bobluck macrumors newbie

    Joined:
    Mar 23, 2009
    #15
    CoolBook Controller

    Hi,
    I've found that after I installed CoolBook Controller this problem started occurring. I removed CoolBook and the problem stopped. If you are running CoolBook Controller see if uninstalling it helps/corrects the problem. If it does please contact the author. I've already done so.
    Thanks
    Bob
     
  16. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
    #16
    I don't have coolbook, but I have this issue on a Gen 1 MBA. I usually just stop/start the network card (Right Click the Airport Signal in the upper right side).

    I've noticed that it likes to try and pick the highest strength signal it can find. So if your primary source is slightly weaker than another source, it pops up the Network Selection box.
     
  17. VS007 macrumors member

    Joined:
    Apr 12, 2008
    #17
    I experience the same issue.
    Usually Rebooting OR
    turning airport off and on OR
    Reconnecting to my wireless network
    fixes the issue. This time it is adamant and refusing to connect to my wireless network. I have also followed the advice listed in this thread. Also spoke to AppleCare and the Tier 1 support guy asked me to take the usual steps like the ones mentioned above and also cleaning the cache dir.
    Still having the same issue, and now waiting for the Tier 2 escalation.

    BTW I have an IBM laptop and that is connecting to my Linksys WRT54G wireless router just fine.
     
  18. VS007 macrumors member

    Joined:
    Apr 12, 2008
    #18
    Update on #17:
    Took my MacAir to Genius Bar and turns out the airport card in my MBA had to be replaced. Thanks to Apple Care, it was fixed for free.
     
  19. jlrosensweig macrumors newbie

    Joined:
    Apr 1, 2009
    #19
    fix for preferred networks problem

    Jsweeney's instructions above, about moving "System Preferences.app" and resetting the preferred networks keychains &c worked like a charm - after much frustration. Interestingly I never had this problem with my old linksys router, but when it broke and I replaced it with an airport express, I did. Silliness, silliness. Anyways for what it's worth I reccommend that fix, and thank Jsweeney.
     
  20. reinalex macrumors newbie

    Joined:
    Aug 4, 2009
    #20
    Thank you very much for this.. I have spent a long time looking for a solution.. I also moved Sys Prefs to my Utilities folder
     
  21. mbernardo macrumors newbie

    Joined:
    Oct 31, 2011
    #21
    This is how I fixed mine:

    1. In the Network Preferences > Advanced window, delete the network name there. Apply your changes and logout.

    2. Login and go back to Preferences > Advanced window, and add your network there. Apply your changes and logout.

    3. The next time you login it will work.

    Hope that helps.
     
  22. zorrie671 macrumors newbie

    Joined:
    Oct 30, 2011
    #22


    worked for me! thanks! :D
     
  23. samarth5stars macrumors newbie

    Joined:
    Jan 30, 2012
    #23
    I have an Imac 27 ". its been 4 months since i bought it . the first two months, it was working fine and i had no problems. But once, for some reason, i had to forget my wifi network. After that, my password would never save even though i had selected the options "remember networks this computer has joined". Can someone help me on this. I have OSX Lion.
     
  24. sensordev macrumors newbie

    Joined:
    Dec 20, 2009
    #24
    Some good tips in this thread, the one that helped me most was going into Keychain to get rid of passwords for an old Airport Express network that I don't use and don't know how to delete (not to mention some incredibly ancient contacts I'd forgotten about on machines long since retired). Installed a new Airport Extreme and let the Lion software do the setup, which was a breeze except for the legacy network lurking in the shadows. I have three generations of Macs accessing the Internet through a common cable input, mix of Ethernet and Airport. After getting the new wireless running all was fine except that on taking a break the Air system would hook up with the old non-functioning wireless. Networks seem to have enough complexity to prevent a good plain English explanation of how to troubleshoot them from being written. Gets even stranger when new meets old but for the moment the password elimination has made everything stable. If you can't get the old bull out of the barn, neutralize it.
     
  25. sensordev macrumors newbie

    Joined:
    Dec 20, 2009
    #25
    This is good advice too, it almost sounds like the old fix of finding the preferences folder for a problematic function and throwing it away. A new folder was created on restart and sometimes you'd have to set something up again. The more things change the more they remain the same.
     

Share This Page