airport not working in OS X? fine in Boot Camp

Discussion in 'MacBook Pro' started by eckndu, Aug 11, 2009.

  1. eckndu macrumors member

    Joined:
    Jun 20, 2008
    #1
    basically my airport is not working under leopard, but works fine in boot camp xp.

    I tried to delete the network history, keychain info, reboot the system, re-enter the password, no good.
    now the airport has a self assigned IP address... I restart to xp, it's fine, go back on os x, no internet:mad: i tho it's supposed to be the other way around.

    yesterday it was fine on leopard.
    pls help me thxxxxx
     
  2. eckndu thread starter macrumors member

    Joined:
    Jun 20, 2008
    #3
    yes im on 8, is this a known issue?

    I did the upgrade the second day it was out, and been using it since without any issue. this just started today.

    (model is unibody mbp with the removable battery)
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    There has been a known issue with 10.5.8 and MBP's with wireless. However, it is said that it works/ works better with the power adapter plugged in.

    If this is a real issue, this will not be the final Leopard update, as Apple cannot leave an OS with a known issue.
     
  4. eckndu thread starter macrumors member

    Joined:
    Jun 20, 2008
    #5
    it suxs apple have to upgrade to bring us trouble.
    i read some recent threads about wireless, ppl are having problems with slow internet or no connection at all. well mine can connect to the network, but it just wont get the assigned IP, Arrrr
    I had to reset two routers to finally realize the problem is my mbp, the thing i trusted the most.
     
  5. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #6
    Could be the .8 problem. Try a new user and/or delete preferences.plist and com.apple.airport.preferences.plist.
     
  6. eckndu thread starter macrumors member

    Joined:
    Jun 20, 2008
    #7
    omg, thanks iLog.Genius, that solved my problem. could you explain the reason behind this? it couldn't just be a simple file corruption?
     

Share This Page