Airport only works when in Clamshell Mode mode

Discussion in 'MacBook Pro' started by wormstrum, Aug 28, 2010.

  1. wormstrum macrumors newbie

    Joined:
    Aug 28, 2010
    #1
    Here's the Story:

    One day I was using my MBP open and external monitor hooked up. Everything was fine until the internet went down suddenly while I was using iChat.

    My airport wouldn't see a network and after a couple restarts and a few resets my airport finally connected to my network. Once connected it would only issue a self-assigned IP, which obviously wouldn't work.

    I was able to get around this by manually entering in the correct info but the speeds were low at best, usually pausing and stalling every minute.

    After frustratingly trying get it to work, I entered clamshell mode because there was no reason at the time to have dual monitors. Once I did, viola, the airport kicked in and started working full force. It's been this way for about a month now.

    My laptop is a MacBookPro5,1 with a 2.8 GHz processor and 4 GBs of RAM.

    I've read that airports will have serious degradation issues if overheated and while that may be the issue, it doesn't seem to be the case.

    I have smcFanControl installed and the MBP seems to be relatively cool to the touch. The fans never seem to be loudly kicking in and I have it raised on a fan powered cooling pad.

    I do, though, use pretty much every port on my MBP. External monitor, speakers, both USBs, and firewire 800 are all in use, so maybe this is a resource issue or a very area specific heat issue.

    I am really stumped on this and any help would be much appreciated. Thanks so much.
     
  2. wormstrum thread starter macrumors newbie

    Joined:
    Aug 28, 2010
    #2
    I decided to do a test and unhook everything and check the internet connection away from my desk (I rarely ever move it).

    It seems to work fine and it appears to be an issue with having the external monitor attached.

    But as I said before, it used to work fine and now doesn't so there should be some kind of fixable issue related to this. Hopefully.
     
  3. wormstrum thread starter macrumors newbie

    Joined:
    Aug 28, 2010
    #3
    Well, I think this is solved.

    Things I did:

    1. Determined it was an external monitor issue because my airport worked without the monitor attached. A possible wifi interference, permission, or graphics card issue.
    2. Used Yasu utility.
    3. Zapped PRAM
    4. Repaired Permissions.
    5. Used iStumbler to determine the least interfered with channel and used my Airport utility to change it. Also, turned off interference robustness and increased the multicast rate.

    When I turned the computer back on, things were good to go.

    Another issue fixed that seems to be connected is when I would turn on my computer with the external monitor connected, the monitor would flash blue as if it was trying to refresh it's connection with the external.

    It would only stop if I unplugged the mini-DVI cord. I would then sign in, re-plug and it would refresh with both monitors.

    This time it didn't flash and connected at start-up. Hope my troubleshooting can help someone in the future. Cheers.
     

Share This Page