Airport problem? Cannot browse internet?

Discussion in 'MacBook' started by thehatboxghost, Sep 16, 2009.

  1. thehatboxghost macrumors newbie

    Joined:
    Sep 16, 2009
    #1
    I got my 13" average white Macbook in April and have not had a problem with it until just now! My airport/wifi shows I have full bars/signal, yet when I open Mozilla or Safari it will not load any pages. It acts as if it trying to load them but refuses to. I feel like I've tried everything. I've turned the airport on and off, I've restarted my Macbook, reset the router, I've tried forgetting then manually re-adding the router, and even repaired my permissions (just in case). This is on my home wireless network, and the other two PC notebooks on my network connect fine to the wireless and browse the internet fine! This just happened all of a sudden and is very frustrating. :(

    Please help! And thank you!
     
  2. rodman109110 macrumors 6502

    Joined:
    Jun 7, 2007
    #2
    It could be the firewall or maybe DNS settings.
     
  3. MacMini2009 macrumors 68000

    MacMini2009

    Joined:
    May 22, 2009
    Location:
    California
    #3
    Restart/reset your cable or DSL modem. If this fails, call your internet provider.
     
  4. GlenL macrumors member

    Joined:
    Dec 16, 2008
    #4
    Yes, it very well could be that the internet provider has an outage. If you have a router, it can look like you're connected to the router, but not to the "internet".

    If not then try the steps in post #8 here:
    http://forums.macrumors.com/showthread.php?t=712208

    If that doesn't work, you can probably take it to Apple store for diagnostics, since it's been less than a year.
     

Share This Page