Airport problem - No IP address?

Discussion in 'Mac Basics and Help' started by soupyjnr, Jul 20, 2009.

  1. soupyjnr macrumors 6502

    Jan 12, 2008
    Northern Ireland, United Kingdom
    Hi everyone - im really frustrated!

    I have had my wireless router for just over 5 years. I got my Mac just over a year ago and its been completely fine with the router - never, ever had a problem with it... until a few days ago

    Basicly, my mac is connecting to the router, but there is no internet connection getting to the mac. When I go into Airport, then Open Network Preferences, and goto Airport, the circle beside Airport is yellow, and under it says No IP address. When I go into advanced, and goto TCP/IP, it is selected Using DHCP.

    Does anybody know why this is doing this. Its working on my mum and brothers vista, just not my mac :( Ive tried rebooting everything, and restoring factory settings... and ive no idea whats happening with it! If anybody can help, it really would be appreciated :D

  2. soupyjnr thread starter macrumors 6502

    Jan 12, 2008
    Northern Ireland, United Kingdom
    I have some more info. which might help to solve this problem! When I go into (my routers home page) and go into Wireless, the Basic Wireless Settings, I changed the Wireless Channel to 8 - 2.447GHz. When I did that and saved the setting, the Airport option in Network went from Orange to Green, and now says Self-Assigned IP, and under were is says Status : On, it is saying Airport has a self-assigned IP address and may not be able to connect to the internet.

    Does this help? Anybody have any ideas?
  3. 1ne macrumors regular

    Jun 16, 2009
    Canada Oil Country
    Even though on wireless G it shows 11 channels, but there are only 3 non overlapping channels. Channel 1, 6, 11. Try assigned a a static IP. IP=192.168.1.x GW192.168.1.1 Give yourself a DNS Then try to ping your GW. Then your DNS. If that works try pinging google.

    Give that a go first.
  4. Jeffrosproto macrumors 6502

    Jun 10, 2008
    I had the same problem, I fixed it by restarting the Router and turning airport off and on.
  5. soupyjnr thread starter macrumors 6502

    Jan 12, 2008
    Northern Ireland, United Kingdom
    Hi - thank you for the reply.

    When I go into Basic Setup and try and select the Internet Connection Type and try and change it from Automatic Configeration - DHCP to Static IP, its not letting me change it. It just refreshes the page and then goes back to Automatic Configeration - DHCP?


    UPDATE :

    Problem fixed! Apparenly my Mac wasnt picking up the IP address automatically and therefore it needed them put in automatically. Thanks for all your help :)
  6. ox4dboy macrumors newbie

    Apr 15, 2004
    I was able to fix this problem by:
    1. Going to system preferences
    2. Click on network
    3. choose AirPort
    4. click advanced button (bottom right)
    5. click TCP/IP
    6. click Renew DHCP Lease
    7. click ok
    8. click apply
    9. go online

    Note: I deleted the AirPort connection (in step 3) added a new AirPort connection (via + button in bottom left) before following these steps - if the steps above don't work, try removing/adding airport and try again.
  7. Doef macrumors newbie

    Dec 4, 2012
    Thanks for your answer, ox4dboy. That worked for me.


Share This Page