Airport Problem on Macbook Late 2008

Discussion in 'MacBook' started by TowleC, Jul 24, 2012.

  1. TowleC macrumors newbie

    Joined:
    Dec 20, 2008
    #1
    So yesterday I was browsing the internet when the wifi showed the ! symbol. So I clicked it and went to turn airport off and then back on. It would not turn back on. So i restarted my computer and then airport said said "no wifi hardware installed." After trying many different things nothing worked, so I decided to do a fresh install of lion. I made a bootable usb and did a fresh install. Now airport is not even installed on my computer... it doesnt show up in the network preferences or anything. I took my computer apart and unplugged the airport card and plugged it back in, but nothing...Any help would be greatly appreciated.
     
  2. Silono macrumors newbie

    Joined:
    Jul 24, 2012
    #2
    I had that problem once before. Can't say how I fixed it because it just started working again... Perhaps it'll do this for you too. If not, there could be something wrong with the card itself. I'd bring it to an Apple Store if there's one convenient near you.
     
  3. TowleC thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #3
    I'm thinking there is something wrong with the card as well...but do you know if there is a way to install drivers for airport or something?
     
  4. Silono macrumors newbie

    Joined:
    Jul 24, 2012
    #4
    Not really. A reinstall should have fixed it. Try rebooting in safe mode by holding down the shift key. If nothing changes, try installing a completely fresh copy of Mac OS X on an external drive or another partition and see if it still doesn't work. If it doesn't work in that case, then yes, it probably is a damaged card.
     
  5. TowleC thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #5
    Will try. Thanks
     
  6. gurinder2010 macrumors newbie

    Joined:
    Oct 23, 2011
    #6
    i had same issue.........i pulled athros wireless card from my acer laptop and tried in macbook and it worked fine. so airport card was bad...... u can order for 8 dollars from ebay.....
     
  7. TowleC thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #7
    Could you please link me to where you found them for $8 on ebay.

    Thanks
     
  8. TowleC thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #8
    Just put in a new airport card, and its still not even showing up in the status bar. Bluetooth has shown up and seems to be working fine though. Someone please help!!!
     

Share This Page