Airport problem with Powerbook

Discussion in 'Macintosh Computers' started by mulls7, Dec 15, 2004.

  1. mulls7 macrumors newbie

    Dec 15, 2004
    Forgive me if this question has been answered before but I am having real problems with the built-in Airport card with my Powerbook G4.
    It works fine for about five minutes and then drops the connections and doesn't see any wireless network. This is puzzling because it has worked fine for the four months I have had the machine. If I switch the machine off for about 20 mins it comes back fine only to go down again after five minutes, whether I am using the Internet or not.
    The only different thing I have done is run the computer occasionally off the battery recently (well it is a laptop) and since then the battery will only recharge to 95 per cent. I know this is highly unlikely to be connected.
    Any help would be most appreciated because the machine isn't much use to me without the Airport card.
  2. gost8go macrumors member

    Dec 2, 2004

    Whoah, I am also having this problem. I was just scanning the threads hoping someone had some answers. It just started maybe two days ago. Yesterday I installed a 1GB stick to get to 2GB. And ran Cocktail's Pilot scripts (clears caches, prebinds, repairs permissions etc)
    Today I updated to 10.3.7.
    My PB 17" is also less than 6 months old.

    What's going on here?

    :eek: :eek:
  3. sAy2k macrumors newbie

    Dec 7, 2004
    airport probs

    I was having probs with my pb g4 when I first got it as well. I was using a non-apple wireless network base station. I would have connnection for a few minutes, but then it would drop off, and I'd have to reconnnect or even reconfigure my pb and base station. I got fed up with it, and I returned the basestation. However, I recently purchaced a airport express and everything works fine. Sometimes the conncetion will drop, but its rare and is fixed by a restart. It sounds like a pain, but really it's only happend 2 times in the month and a half that I've had the airport express base station. I was thinking that maybe your problem might be with the basestation if it's non-apple.
  4. Gee macrumors 65816

    Feb 27, 2004
    London, UK
    If it's a home network you're having trouble with, it might be that you're getting interference on the wireless channel you're using - from a neighbour's microwave or something. Try changing to another channel. Worked for me - I had the same problem about 6 months back, and since i swapped to another channel it's been fine.
  5. gost8go macrumors member

    Dec 2, 2004
    Thanks for the suggestion. I'll change channels and see what happens. If been using a Netgear base station for the past 2 years and have had only these two problems this week.

    What's strange about it, is I can get it back up if I restart but not if a reload the finder.
  6. mulls7 thread starter macrumors newbie

    Dec 15, 2004
    Thanks for the help. I have a linksys router because we have macs and PCs in the house. I have looked on the base but cannot see any way of changing the channel.
    Can anyone give advice? If I got an Airport base station, would this work with the PCs?
  7. RichardJ macrumors newbie

    Dec 20, 2004
    As a first time user, please excuse me if I butted in on the conversation. This may not be relevant.
    I have recently installed Airport Express v.4.1 on my PB G4 OS X10.3.6. And have had some problems which were solved after an expensive conversation with Apple resulting in a re-set while both live and again disconnected.
    But now, contact with all mail and web sites works perfectly except Google! I have it as my home address and it was working perfectly when without warning it now absolutely refuses to make contact with it.
    Even if I enter the address entirely from scratch it comes back with "Unable to connect to this server" or "the specified server could not be found"
    I can make contact without prob, using hardwire, on the same machine, or using another machine on the same ethernet LAN. I do not get this report from any other site!
    Help! Any suggestions?
  8. emw macrumors G4


    Aug 2, 2004
    I am assuming you're using the WRT54G or that the interface will be somewhat similar. You have to go through the admin interface (there is no switch on the hardware itself). In there, go to the Wireless > Basic Wireless Settings > Wireless Channel to change the channel to something else.
  9. emw macrumors G4


    Aug 2, 2004
    Sounds like it may be a cache or preferences problem, since it's only with one site. You can try going to the Safari menu > Empty Cache..., or try deleting the Safari prefs.

    What if you try to access it wirelessly from another browser on your PB? That would determine if it is indeed a Safari problem.
  10. mulls7 thread starter macrumors newbie

    Dec 15, 2004
    Just wanted to thank everyone for the brilliant advice. I have changed channel on the base station and everything is working fine now. Must be a rogue cordless phone on the loose in Liverpool! (where I live)
  11. gost8go macrumors member

    Dec 2, 2004
    OK I've tried changing the channel a few times and am still losing conneection to the wireless network. It drops and disappears on my pb even though I can still use it on my iBook (no problems ever).

    The problems seems to manifest itself faster when I"m trying to use bittorrent. I've tried both the bt client and azureus.

    This is ANNOYING. I am spolied by problem-free macs. :)
  12. crackrock macrumors member


    Jul 20, 2004
    Cracktown, USA
    Go to versiontracker and download AP Grapher. It shows a live graph of your signal strength. See if it drops just a little or goes all the way down to zero.

    I know with my powerbook if I turn on my microwave (It's an OLD microwave, so it probably leaks a LOT of radiation) my signal goes from 90% to zero. Perhaps your neighbor is talking on a cordless phone.
  13. gost8go macrumors member

    Dec 2, 2004
    Did that. The graph goes to zero at the same moment the bt client actually connects to some peers. The other wierd part is, I can't get the wireless back without a restart. :mad:

    Could it be memory related? BT seems like it has huge memory leaks.
  14. gost8go macrumors member

    Dec 2, 2004
    I think I answered my own question. I removed the 2nd 1GB stick I had recently installed and now bittorrent is rocking and my connection is not dropping.

    I bought it cheap ($159) off and it worked ok for the first week or so under my normal use but now I'm blaming it for interfering with my airport card. Too "noisy"?

    Any memory recommendations? This stick's going back.
  15. imac abuser macrumors 6502a

    imac abuser

    Mar 1, 2004
    I trouble shoot high speed internet for a living, and Linksys Gateways. I tell people all the time that have these type of problems to throw those 2.4 ghZ cordelss phones out the window, and watch your troubles go away. I mean the most routers work on 2.4 gHz freq. What's so hard about figuring that out. lol

    Also make sure the number of cpe's (computers using the network) is correct in the router. I have found other then airports, D-Link routers work well with Apple products.

    One last note 99% of my customers are PC users lol proves again MAC RULES!
  16. gost8go macrumors member

    Dec 2, 2004
    I haven't had a cordless phone in 4 years. No land phone neither. :cool:
  17. imac abuser macrumors 6502a

    imac abuser

    Mar 1, 2004
    No kidding huh, with cell phones and Voice Over IP lol...

Share This Page