airport problem!

Discussion in 'macOS' started by iamamac, Nov 5, 2008.

  1. iamamac macrumors member

    Joined:
    Oct 3, 2008
    #1
    i have a 15'' macbook pro (2007) and a secured wireless network in a wireless router.
    my mbp keeps disconnecting almost every 5 minutes.then i have to turn off the ap,turn on the ap, insert EVERY TIME I CONNECT THE PASS (even if the remember pass box is checked) and redo this step every 5 minutes.
    it's really annoying!
    oh, and for some reason sometimes i turn on the ap,connect and sais "self assigned ip" and i got no internet connectivity.
    IN MY WINDOWS PC EVERYTHING WORKS GREAT!
    it's a shame.
    oh,and if i set up the wifi router again with no password..guess what..it works!
    the same thing happens on my APPLE! Airport Express.
    please help me, what shell i do?:mad:
     
  2. Atomic Dude macrumors newbie

    Joined:
    Nov 5, 2008
    #2
    wow i never thought vista would do something bettr than mac:D

    im not really sure whats happening to your airport but its either other networks interfering, somthing really wrong with it or u hav a crappy router...
    so what i wud do is :
    -check diagnotics
    -try connecting to other networks and see if u have the same prob
    -turning off airport for at least 10 min.
    -Repair permissions (Disk utility - search in spotlight)
    - if ur desperate how about conecting via ethernet
    - And if ur really really desperate call APPLE technical support

    PS i dont know why you dont get an internet connection when self assigned ip ... but it might be the another computer having the same ip so it really might be ur router ... try checking in system prefrences>network> airport>advanced>TCP/IP, make sure that IPv4 is configured 'using DHCP' and IPv6 is 'automaticaly'
     
  3. iamamac thread starter macrumors member

    Joined:
    Oct 3, 2008
    #3
    I checked the diagnostics.
    On my airport extreme doesn't have any problem.On the neighbor's network :D doesn't.On my WCDMA and Ethernet internet key no problems so far.
    I have turned off the airport for at least 2-3 hours while i was surfing the web using my Wcdma key.
    Also repaired the permissions.
    I can't connect via Ethernet because my router it is faaaaaar from my room. That's the reason I bought a N+ router, with three antennas.
    Oh, i forgot to tel: MY iPHONE IS WORKING PERFECTLY.
    Also, if i remove the password, my macbook does.

    :eek::eek::eek:
     

Share This Page