Airport Problems. Apple cant even help

Discussion in 'MacBook Pro' started by JBot, Nov 4, 2006.

  1. JBot macrumors 6502

    Jan 9, 2006
    I have run into the wierdest problem with the internet connection i have ever heard of.
    Heres the basis:
    I have a powerbook, g4, which was connected to a wireless g linksys router. I had a connection, than one day, (three days ago) i couldnt get access.
    The internet is still up, as the other pc laptops that my roomates run can connect, but mine and my roomates (macbook) cant get a connection.
    I go into the network settings under system prefs., and it says: Aiport has a self-assigned IP address and may not be able to connect to the Internet.
    I have tried the basics, testing every setting available, renewing dhcp lease, restarting the computer holding apple option r and p, but i still cannot connect.
    The airport card is not broken however, because i can connect to the internet when i go to school and other hotspots, (coffee shops etc.).
    When i plug my computer into the router, it has the same problem, and when i connect the computer directly into the modem, bypassing the router, i STILL have the same problem.
    I finally gave up and called apple support yesterday, and after an hour of working with some guy, (who provided me with no extra support than the manuel had), he finishes the conversation saying to check the internet forums for the answer, as there is no known reason why this would be happening that he could think of.
    And i did update my airport software yesterday.
    Im really hopeing someone here can provide some help, because myself, my roomates, my prof, and the apple support can not figure this out.

    Thank you very much!
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Well, I'm not sure if you've done this already but the first thing I'd try is to open a new location and reconfigure my settings in that location to see if it gets any further.

    Having said that, the fact you upgraded your AirPort software and then started having problems seems to make it pretty clear that the update is the cause. I don't know of any way to backtrack or uninstall such an update without performing a complete OS install though. I'll look into it. :eek:
  3. JBot thread starter macrumors 6502

    Jan 9, 2006
    i ran into the problem prior to installing the new version for the airport.

    As well, i have laready opened a new location and tried reconfiguring everything.
    I have also reinstalled the entire os, after formatting the entire harddrive. Both of which have done NOTHING.

    I honestly have done everything i could think of except throwing my laptop against the wall, which is my next plan of action.
  4. iBorg20181 macrumors 6502


    Apr 5, 2006
    Minneapolis, MN
    Before you do that, I'd have someone bring their wireless router over to try connecting to.

    Interesting that all the PCs can connect and neither of the Macs are able to ... If someone else's router works, maybe buying a new one is necessary (with rebates, I've seen name-brand wireless routers for $25).

  5. JBot thread starter macrumors 6502

    Jan 9, 2006
    thats what we are doing today, however, when i plug the mac into the modem, i still dont get a connection, which leads me to believe its not the router.

    To make matters worse/more confusing however, the macbook was working, it was connected to the internet. Than i disconnected the router from the modem and plugged the ethernet directly into my laptop, found out the connection didnt work, so i plugged the modem back into the router, and reset it, and THEN the other mac couldnt get a connection. The pcs have never had a problem, as that is what im posting from currently.

    If no one knows how to fix it, can someone atleast tell me what i should do/ask? Im thinking of calling shaw (internet provider) and getting them to come here to try to fix it, but i already know that the guy they will send here will never have worked with a mac, and say its not his job.
  6. OldSkoolNJ macrumors 6502


    Jul 10, 2006
    Was there a software update other than an airport spftware update you two may have dopne that night?

    I cant narrow down the problem but I can tell you to try taking your computers somewhere else to see if you can connect to the internet. Not just bringing in another router.

  7. JBot thread starter macrumors 6502

    Jan 9, 2006
    I can connect to other locations.
  8. Pressure macrumors 68040


    May 30, 2006
    I ran into the same problem at my parents, while I was home to set their Mac up to the internet.

    Self-assigned IP address and this is with the adsl modem connected right to the ethernet port. Tried with my own MacBook Pro and the same. No problems at home where I connect wireless.
  9. Tat macrumors newbie

    Oct 30, 2006
    As you may already know, Self-assigned IP means you couldn't get IP address from DHCP server (usually router).

    What I'm wondering is if your router recognizes these Macs at Wifi level.
    Could you check the router stats if it shows the MAC address assigned to
    the airport adapter in your PB?

    If it does, either DHCP or security configuration could be wrong.
    If it doesn't, it means there is no wireless connection. The problem can be various including encryption configuration (WEP, WPA, etc), MAC address filter, interfared by other surrounding wireless router.

    If I were you, I would try configuring the router like:
    - disable all security options; WPA/WEP, MAC address filters, etc
    - enable SSID broadcast
    - use different WIFI channels (6, 7, or whatever).
    - enable / disable UPnP

    Changing one option at a time may tell you what's wrong with the connection.
  10. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Have you tried throwing the preference file away?
  11. SMM macrumors 65816


    Sep 22, 2006
    Tiger Mountain - WA State
    If I understand your posts, I would suspect your ISP has made some change to their DHCP. There are several possible changes to their DHCP Pools which could possibly cause grief. You might try:

    Print out one of the PC's IPConfig. Go to a Mac and enter the values as a static IP configuration. Remove the PC from the network and see if the Mac can get a connection. If it does, then you know the problem lies with getting a DHCP lease. That should help your ISP. They should be able to see your attempt to connect in the 'unregistered' pool. They might even find the 'smoking gun'.

    It could be something easy like not looking in the right place for the dhcClientID, and not having a default set.
  12. jlcharles macrumors 6502

    Mar 30, 2006
    Wenonah, NJ
    As an aside, if you have a DSL modem connected to the router, you wouldn't be able to connect to the internet by directly using the modem into your ethernet. Most DSL modems would be set up in "Bridge" mode when connected to your router. So instead of the modem storing and sending the username and password, the router does.

    So, my guess is the problem lies not with the modem, but your router, especially if you can connect to other hotspots.

    Try completely resetting the router to factory defaults and setting it up again. Most routers have a button that can do that.

    What kind of a router is it?
  13. PygmySurfer macrumors 6502

    Aug 7, 2006
    Wellesley, ON
    Other laptops in the apartment are connecting to the internet through the router, he doesn't need to wipe out the configuration.
  14. JBot thread starter macrumors 6502

    Jan 9, 2006
    How would i go about doing that?
  15. bodeh6 macrumors 6502a


    May 18, 2005
    Have your tried to update the Firmware on the router and then resetting it?
  16. JBot thread starter macrumors 6502

    Jan 9, 2006
    Yes i have. Im running Linksys' wireless g router, WRT54GL, with the most recent updates.
    To make things more confusing, my girlfriend brought her iBook g4 over last night and it can connect to the internet.
    So now i know its not the computer that is the problem, but the settings that are on my computer. (Although they have been every possible configuration i could think of), as well as factory.
    I baught a new router yesterday, gave it a whirl, its not that, which i knew already, but wanted to exhaust every possibility i could think of.
    Now that that has happened, the only thing i could think of doing is plug the router into my pc desktop. haha, funny story is, the ethernet cable was about 10 feet too short. We cant move it from the back room, as our entire house only has 2 cable outputs, which are being split multiple times. Were keeping it in there so its the only connection not being split. You could only imagine the amount of alcohol consumed and hours of playstation was spent after i found the cable to be to short.
    Oh the joys of school stress/everything else.

    If someone could tell me how to completely erase the preference file, that would be GREATLY appreciated.
  17. Hammockgirl macrumors newbie

    Feb 6, 2007
    Toronto, Canada
    JBot - did you resolve your internet connection problem?

    I am going through this now too:
    "Aiport has a self-assigned IP address and may not be able to connect to the Internet."
    I can't connect at home thru wireless or ethernet, my parent's place either, but can connect at the office wireless.
    this stinks because I am unable to work from my home office now, which is my main office 4 days a week.
    if you fixed it, please let me know what you found the problem to be. I would appreciate it greatly.
    thanks a million.
  18. macuser1111 macrumors newbie

    Sep 1, 2008
    Same problem

    I have been a Mac user for over a decade.
    I think I know them pretty well, but this issue is baffling.
    I get a signal, I even get what tells me is an IP address in the network settings.
    When I launch Safari, it tells me I am not connected to the internet.
    I can conenct wirelessly using my iphone, may apple TV, and any other laptop entering my house-including PC's.
    The problem is NEITHER the router NOR the ISP. I've eliminated that as a possibility. And so have many others here.
    COULD this be a virus?
    What's the deal? Is Apple becoming aware of this APPARENTLY growing problem?
    Conspiracy theory: the government has zapped computers it feels have visited a site it deems subversive!
    Sort of like when the cable companies sent a signal that fried all boxes with illegal connections, then busted those same people when they came in to complain about the problem...ooooh!
  19. bluewhite4 macrumors member

    Jul 11, 2008
    Beloit, WI
    This maybe a long shot, but if you think you have fully connected to your wireless network, can you open terminal, and ping If you get a reply then you truly are connected and should be able to view websites. If you can't ping, can you ping
  20. antmo macrumors member

    Feb 20, 2008
    as a previous poster mentioned, it could be a dhcp setting changed from the provider's end...

    try giving your mac a static ip in the wifi router and setting up your wifi on the mac to be that static ip...also find out what your dns servers are (from the pc's or from the router or use opendns) and manually specify these on your mac as well... this will eliminate dhcp from the equation.

  21. macuser1111 macrumors newbie

    Sep 1, 2008
    I solved my problem

    Well I am not going to tell you that my solution will be yours, but here goes...
    So after visiting a coffee shop with free wireless to confirm that it was, in fact, the computer itself, I learned just the opposite.
    The Powerbook G4 WAS able to connect with their wireless.
    So now it was back to the ISP with more questions.

    It turned out to be a simple, yet elusive, solution.

    My ISP is AT&T u-verse. The wireless router is an EWIRE unit that handles television and internet. It has wireless, coaxial and ethernet connection capability. It handles three three TV's by hardwire. It is also linked with a PC laptop, an iphone and a PS3 with no issues. The G4 laptop and the AppleTV were having problems.

    Turns out that, on restart, those two units were dumped. The system was asking for the WEP-password. There are two number sequences on the unit itself. Although mine are default-assigned, they can be changed.

    One is system password-which is the obvious choice. But what I NEEDED to use was the WIRELESS NETWORK KEY. when it was asking for password, I got misled.
    And that solved everything immediately. We're fully up-and-running.
    I hope it helps out at least a few people with this issue!

Share This Page