Airport problems

billwest9999

macrumors member
Original poster
Mar 3, 2004
36
0
I have a 1.5GHz powerbook that just won't connect to my wireless router anymore. The router is just 3 rooms away. The strange thing about this is that I used to be able to connect without any problems. But all of a sudden (last week) I couldn't connect anymore. It's a DLink router, and it still works with my windows laptop. Any ideas?

Thanks.
 

damgpro

macrumors member
Aug 25, 2004
34
0
nyc
Are you able to get a wireless signal at all? Or, do you get a signal but can't go anywhere from there?
 
Comment

billwest9999

macrumors member
Original poster
Mar 3, 2004
36
0
No signal at all. Though I can see the network. Also, I can't get an ip (DHCP on).
 
Comment

mad jew

Moderator emeritus
Apr 3, 2004
32,199
5
Adelaide, Australia
Fingers crossed that I'm wrong but it might be a loose AE antenna. Sorry, but I have absolutely no idea how to fix these other than to take it to a technician. :(

Hopefully I'm wrong and it's merely a software problem in which case it can be fixed relatively easily. :)
 
Comment

billwest9999

macrumors member
Original poster
Mar 3, 2004
36
0
Yes I've tried reseting and stuff. Strangely, I can able to connect to other wireless networks without any problems. Just can't connect to mine at home (although my window laptops can connect to it).
 
Comment

Monk Edsel

macrumors regular
Apr 7, 2004
193
0
Mmm, now that I think about it this has happened to me a few times, it's like the router has just vanished. I had to click the AirPort icon in the menu bar, select Other..., pick the kind of security, and then type in the name and password of the network to log back on to it. It hasn't happened in a while though.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.