airport suddenly not detecting ANY networks

Discussion in 'MacBook Pro' started by reblevitan, Jan 13, 2011.

  1. reblevitan macrumors newbie

    Aug 26, 2009
    I have a MacBook Pro from 2009. The airport has abruptly stopped finding any networks. I have had problems in the last few months (just after I moved to the states from Canada). My roommates' laptops could pick up the network, and mine kept dropping out. I went home for the holidays, and it worked fine (despite the router being even further from my computer).

    when i returned, i had a few days of very spotty internet (much higher number of drop outs) and now it won't detect a single network. My warranty is up so i'm nervous that this is something internal they have to replace, but I"m hoping there is some way for me to check. I just tried to connect at work, and it detects nothing here too. so it is NOT interference.

    sidenote: My graphics card is malfunctioning (which is under extended warranty for this model), and I am taking that to get replaced today... is there any crazy conceivable way that the two issues could be connected???

    bottom line: what can I do now to rule out (or in) the possibility of hardware malfunction causing my airport to stop detecting networks?
  2. jenzjen macrumors 68000

    Aug 20, 2010
    Make sure to tell the Genius and be nice, elicit sympathy, if it needs a hardware fix, they might just go ahead and do it.
  3. eldy macrumors 6502

    Jan 30, 2009
    The City
    search for instructions to reset your PRAM and SMC. resetting the SMC worked for my macbook pro when the wireless was acting dodgy.
  4. revelated macrumors 6502a


    Jun 30, 2010
    You can try the magic fix another guy posted which cured my MBP2010's ailments in this arena. Post information from Mark Johannes, down the page.

    Another thing I have observed is that the MBP really doesn't like hidden SSIDs over time. It'll work fine out the gate, but eventually it'll get to the point where it just won't remember the network and you have to keep manually putting it in. The deleting of prefs fixed it for me, but I had to also make my SSID visible. Haven't had an issue since, but it is rather infuriating that I had to do that.

Share This Page