Airport trouble on iMac 27"

Discussion in 'iMac' started by E.from.B, Jun 23, 2010.

  1. E.from.B macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    Brussels, Belgium
    #1
    Hi,

    Since the latest update of OSX, I'm encountering trouble with my WiFi connection.
    My old sony laptop has no problem connecting, so I'm guessing the problem must be with the iMac, and not with the network.

    When I boot the mac, everything is OK, I get connected. But after a while (less then half an hour) it looses connection to internet. In the airport icon appears a " ! ".
    To get my mac back on the network, I have to reboot it.
    It's not a signal problem, my mac always finds the network, but it doesn't connect. My password is asked, I'm sure I entered it wright, but it's asked over and over, no connection possible.

    I tried changing DHCP to a fix IP, deleting the network and reconnect as if it's a new one, and little stuff like that, nothing helps.
    Only way is to reboot.

    Somebody any idea?

    Greeting from Brussels.
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Try removing the SystemConfiguration folder in /Library/Preferences. Restart and see if it improves.
     
  3. E.from.B thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    Brussels, Belgium
    #3
    Hi,
    It has been better for a few days, but since yesterday it doesn't work at all again.

    I've been looking for that folder, but I was unable to find it.
    When I look with finder into "my computer"/library/preferences the only folders I have is Macromedia and ByHost, the rest are .plist files.

    I'm new on mac, maybe I'm doing it wrong or looking at the wrong place :)

    Thx for your help.
     
  4. E.from.B thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    Brussels, Belgium
    #4
    AHA !!! :)
    I found the folder.
    As I said, I was looking in "my computer", but I looked some more around, it's on "macintosh HD".

    I deleted the folder and restart, but nothing changed. Had no internet at all.

    Other ideas? :)
     
  5. E.from.B thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    Location:
    Brussels, Belgium
  6. Gakboi macrumors regular

    Joined:
    Feb 15, 2010
    #6
    airport is terrible.. nothing but issues with mine... all none mac pcs work fine on same network... so i now just use a cable... the only way to go

    I wish apple would sort out this obvious weak spot in their computers. I don't understand how everything else works like a dream but this and it seems I'm not the only one to complain.
     
  7. actionman133 macrumors newbie

    Joined:
    Feb 6, 2010
    #7
    -Check the security on your wireless network. If it's WEP, try setting it to WPA (WEP is a loose standard that everyone implemented differently and it never really worked well... WPA is more solid).

    -Try changing the wireless channel on the router. It's possible it might be broadcasting on a frequency that the mac doesn't receive well - I've seen this before and changing the channel has fixed it.

    -Try bringing the iMac and the router closer together. It might just be interference. Your laptop might be okay but it's made out of plastic and the signal can get out of the box easily. An iMac is made out of aluminium and it does block the signal somewhat, which might explain why it's dropping.

    I would try those to narrow down what the problem is. Chances are, one of these will fix it.
     
  8. Gakboi macrumors regular

    Joined:
    Feb 15, 2010
    #8
    Noooooo... don't use WPA use WPA2 .. WPA is easy to brute force hack
     

Share This Page