Airport won't turn off

Primejimbo

macrumors 68040
Original poster
Aug 10, 2008
3,295
131
Around
So I went to my in-laws house and for some reason I couldn't connect to their Airport/Router. I was on it once before and none of the settings were changed because I was on the router with my iPhone at that point. So I tried to turn off my Airport on my Mac just to see if that would work, and it won't turn off. I restarted my computer and nothing, still stays on. I turned off my Time Machine just to see if that was the issue and it wasn't. I will probably make an appointment with Apple and maybe call Applecare, but just wanted to see if anyone had any ideas here 1st.
I am now back at home and stuff can't turn it off. If it helps I am running Snow Leopard on my Mac.

Thanks
 
Feb 15, 2009
5,489
1
Boston, MA
First, try a PRAM reset.

Also, try deleting com.apple.airport.preferences.plist, NetworkInterfaces.plist, and preferences.plist form /Library/Preferences/SystemConfiguration and restart your computer.
 

Primejimbo

macrumors 68040
Original poster
Aug 10, 2008
3,295
131
Around
Repair your permissions then then reboot the computer and try again. See if that helps. :)
That's under Disk utility? then I select Mac HD and select "Repair permissions"?

First, try a PRAM reset.

Also, try deleting com.apple.airport.preferences.plist, NetworkInterfaces.plist, and preferences.plist form /Library/Preferences/SystemConfiguration and restart your computer.
I followed that path and when I got to /Library/Preferences I didn't see a "SystemConfiguration"
Also what's a PRAM reset? sorry I am still learning things here.

EDIT: I found out how to do a PRAM reset and it didn't do anything.
 
Feb 15, 2009
5,489
1
Boston, MA
That's under Disk utility? then I select Mac HD and select "Repair permissions"?



I followed that path and when I got to /Library/Preferences I didn't see a "SystemConfiguration"
Also what's a PRAM reset? sorry I am still learning things here.

EDIT: I found out how to do a PRAM reset and it didn't do anything.
You need to make sure you go to Macintosh HD>Library>Preferences and find the folder. You went to your user-specific Library.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.