AirPrint Woes

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mikedamirault, Mar 10, 2011.

Thread Status:
Not open for further replies.
  1. mikedamirault macrumors newbie

    Joined:
    Oct 14, 2008
    #1
    I have been trying to get AirPrint working on my iPhone 4 (CDMA/Verizon) for a while now without success

    I know that the AirPrint feature is designed to work with AirPrint compatible HP WiFi printers (as Apple dropped support for OS X), though I have no plans on buying a new printer when I have 2 perfectly fine printers shared on the network, let alone one specifically designed to work with AirPrint

    I have tried out AirPrint Installer 1.3 for Windows (running on WinXP MCE 2005), but can't seem to get it to work properly

    After installing AirPrint Installer, I was able to see one printer from the iPhone (from a laser printer shared from another computer on the network), and was able to send a print command from the iPhone to the XP MCE computer, but I kept getting "Error-Printing" from the print que (on XP MCE)

    After sharing a printer connected locally (via USB), I was able to print from my iPhone once successfully, but nothing from the iPhone would show up in the que on XP MCE since

    Since then I have also shared the Microsoft XPS Document Writer (saves "printed" documents to an XPS file) as a way to tinker around with AirPrint without wasting paper, ink, and/or toner, and was unable to print from it

    Now whenever I attempt to print from my iPhone, I have the option of 3 printers, the shared laser on a different computer on the network, the local inkjet via USB, and the Microsoft XPS Document Writer, selecting any of them will then give me a message with an image of a piece of doggy eared paper saying "Printing to "<Printer Name>" Sending to Printer" as if it's about to print, but there is no change on XP MCE, the print cue shows nothing, and nothing prints and I don't get a popup asking where I would like to save (when using the XPS Document Writer), yet I can print fine from the computer itself

    Also, I have noticed that after a while, the printers will disappear from the list (on the iPhone) one by one, and I have to constantly uninstall and reinstall AirPrint Installer, only for it to not work again

    Am I doing something wrong? I have updated iTunes, I don't have a software firewall, and I am pretty sure I have installed AirPrint Installer 1.3 correctly

    I have also tried using AirPrint Activator and AirPrint Hacktivator on my MBA, but I only have Leopard on it (haven't upgraded to Snow Leopard yet, and may not for a while), so AirPrint Hacktivator will close unexpectedly (constantly), and AirPrint Activator gives me an error saying I need at least Snow Leopard, also, even if it did work, I very rarely use USB printers on it, and most networks it is on are Windows/PC dominant, and I have had issues trying to connect it to Windows/PC printer sharing, so getting AirPrint Installer 1.3 for Windows to work would be much appreciated
     
  2. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
  3. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #3
    Bump

    Seriously, am I the only one using AirPrint Installer 1.3 and having problems? Out of 63 views, I'd expect at least ONE reply :mad:

    Then again maybe I shouldn't expect much, I have started 2 other threads in the past on here, only to end up answering my own question

    I understand if nobody knows the answer to my question, but it would be nice to get at least some response so I don't feel like I'm getting ignored
     
  4. himni macrumors regular

    Joined:
    Sep 24, 2009
    #4
    Jailbreak and get TruPrint is a good solution. Then you can print to any printer on any network your iPhone is on.
     
  5. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #5
    Being that I just got my iPhone (notice how I said it was a CDMA iPhone on Verizon, just released last month), and that I got it on my plan, therefore only needing to spend $214 (getting the CDMA iPhone without a plan would cost upwards of $700), the last thing I want to do is Jailbreak my iPhone and risk it getting damaged or Verizon not supporting it if I have issues with it

    The Airprint feature on the iPhone works just fine, the iPhone is not the problem, the problem is with the Airprint Installer software, IF I were to buy one of those printers with AirPrint capability, it would be working fine and I wouldn't be on here posting this, the only reason why I am posting this is because I am not willing to go out and blow another $300+ on a brand new printer when I can just install software

    The problem is, even though AirPrint Installer is telling my iPhone that there are shared printers, and the iPhone is able to interact with the AirPrint Installer software, the software is somehow refusing to send the print job to the printer cue, now this can be due to an incorrect setting, some sort of glitch or incompatibility, or any number of things, i'm just not sure what, and therefore I am not able to spot the problem to fix it

    The reason why I asked here, is I am pretty sure that other members here have also used AirPrint Installer, and probably have ran into the same problem as I have, found out a fix, and would be willing to pass that info along, I guess I was wrong in thinking that, though I did expect that if nobody knew, that at least maybe somebody could point me in the right direction

    And no, Jailbreaking a brand new iPhone is never a good solution, it requires unsupported and unofficial code to be ran on the iPhone, which is never a good idea unless you are willing to risk breaking it, which I am not willing to do
     
  6. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #6
    Hmm, 103 views, one unhelpful reply

    Well, I am going to assume that no one on the forum has ever used AirPrint Installer, or has used it without issues

    In that case, is there a place where someone might know that could help?

    I do find it funny that for an Apple based forum (even though unofficial), whenever I come to ask an Apple based question, nobody is able to answer my questions
     
  7. P279 macrumors newbie

    Joined:
    Mar 13, 2011
    #7
    Airprint

    Ever thought it might be your attitude and personality
     
  8. Alonzo84 macrumors 6502a

    Alonzo84

    Joined:
    Dec 18, 2009
    Location:
    North Carolina
    #8
    +1

    OP, you posed this question less than three days ago. You can't demand immediate assistance from an online forum. The solution himni provided less than 24 hours after your first post was reasonable but you rudely shot it down.
     
  9. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_6 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E200 Safari/6533.18.5)

    I understand how forums work, I have been on many other forums, so I know they are not instant, but at the same time, I should be able to get a response within 30 minutes to an hour, it doesn't take longer than 24 hours for somebody to spot a thread and post to it

    Also, I noticed how many people viewed the thread, when I notice that there are more than 10 people viewing a thread, either they Are ignoring the OP (me in this case), or if they don't know the answer to the OP's question, they'd rather not reply than reply to say they don't know

    The reason why I blew off the first guy to reply, is because he said that I should jailbreak my iPhone, as if that was the only way to make it work, which I found unhelpful, so after waiting a while for a reply, only to get a reply saying to just jailbreak it, of course I'm going to be angry, it would be like going to a store and going to ask a clerk about a product, only to have him turn his head, I know this is an unofficial forum with no Apple staff, but the point still stands, and I find that behavior a bit rude

    An update since my last post, I went to an Apple store yesterday to pick up an iPhone HDMI adapter, while I was there, I asked about my AirPrint, and while they were unable to answer my question, they kindly guided me to the official Apple forums, which i may end up just asking over there

    And while my replies may have been a little offensive, that's only because I have asked 2 other questions on here, one of them being quite an easy answer, and I have never gotten an informative answer from this forum, none of the threads I have started have ever had an offensive tone in the beginning, only when I don't get any helpful information whatsoever
     
  10. himni macrumors regular

    Joined:
    Sep 24, 2009
    #10

    Jailbreaking cannot break the phone. At most it would do is make you have to restore via iTunes. I jailbroke my iP4 the second the jailbreak came out (which was a month or so) and haven't had a problem since. If something happened to your phone you could restore it via iTune and take it to the apple store or verizon and they would never be able to tell it had been jailbroken.


    If you want to use airprint the way it was meant to be used (meaning with almost any network connected printer) then follow the directions I posted before.

    ETA: The reason I say Jailbreak is because you are trying to do something that apple doesn't support doing with airplay. So instead of using software on a computer to do what you want JB and download some software that unlocks to full potential of AirPrint. The software I suggested does just that. If that is the only thing you wish to do with the JB then you need to do nothing more and leave everything the way it was.
     
  11. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #11
    You still miss the point, I said that I didn't want to jailbreak, and I shouldn't need to in order for this to work

    Like I have said before, the iPhone portion of AirPrint works perfectly fine, why jailbreak to fix something that works perfectly fine?

    The problem has to do somewhere on the computer side of things, either something I am doing wrong, some glitch with the software or OS, or something wrong with the system, I am just not sure which, and was hoping that someone that has used AirPrint Installer would know, or had the same issue

    Even if I did jailbreak my iPhone, it wouldn't help me, I would still be stuck with the same problem I have now, plus an iPhone jailbroken for no reason, and not covered by Verizon or Apple (whether they figure it out or not), both printers are wired to a computer, a laser connected via parallel, an inkjet connected via USB, and the Microsoft XPS Document Writer which is nothing more than software, none of the printers have networking hardware in them, let alone being able acquire it's own IP, so a computer would need to be running regardless to host the printer
     
  12. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #12
    Alright, another update, I just learned something new

    After browsing the Apple support site, I came across a tips and tricks page, one of the tips being how to access the task list, and inside that task list, the Print Center (why this can't just be an app on the main app screen, I don't know:rolleyes:)

    Anyway, when looking in the iPhone print cue (in Print Center) I have noticed some incomplete jobs, most of them being to Microsoft XPS Document Writer, and it seems to be hanging on this

    As soon as I clear all the print jobs going to Microsoft XPS Document Writer and choose another printer from the list, Voila it works fine... Well, it works fine to the inkjet connected directly connected to this computer, I still get "Error-Printing" when trying to print to the laser, but I think that is an issue between AirPrint Installer 1.3 and the Windows Printer Sharing print que

    Anyway, I have come down to the understanding, using the process of elimination, that Microsoft XPS Document Writer is the culprit, causing to to tie up the print que, and the whole time AirPrint WAS WORKING FINE (and for the third time, I have answered my own question;), keep that in mind)

    Anyway, now that I figured that out, it would be nice to know if others would have the same problem if they attempt to print to Microsoft XPS Document Writer

    So for anybody using AirPrint Installer 1.3 on Windows XP or higher, can you please share your Microsoft XPS Document Writer, then attempt to print from it from your iPhone, then post your results? I would like to know if indeed Microsoft XPS Document Writer is incompatible with AirPrint
     
  13. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
  14. mikedamirault thread starter macrumors newbie

    Joined:
    Oct 14, 2008
    #14
    Umm, excuse me? Is bumping a thread against the ToS? I only did so to keep the thread visible so someone could find the thread to help
     
Thread Status:
Not open for further replies.

Share This Page