Airprint working then 1 printer stopped showing up

Discussion in 'iOS 8' started by Ristin, Sep 7, 2015.

  1. Ristin macrumors newbie

    Joined:
    Oct 11, 2011
    #1
    Had Air print working fine on a Windows 7 machine. All iDevices could see both networked printers and print just fine. I don't print much from my iDevices but my wife does and she said she could no longer print to the Dell Color laser, our primary printer.
    I have not made any changes to our network. Air print and Bonjour are running, iTunes is installed. I have the Dell and an old HP Laserjet 6L on our network. The Dell has built in networking and is assigned a static IP address. It is shared on the Win machine running Airprint. All other computers can see and print to the Dell. The HP is out in my shop, connected to the network via an HP JetDirect 300 and a wireless N bridge also on a static IP. The iDevices can see and print to the HP.
    I have tried rebooting the router, printer, computer and iDevices. I have tried iOS 6, 7 and 8 all only see the HP. I have stopped and restarted Airprint. I have unshared and reshared the Dell. Nothing works. Last resort is to remove Airprint and reinstall but hoping to avoid since it was a pain getting it working right the first time.
    Any suggestions?
     
  2. Ristin thread starter macrumors newbie

    Joined:
    Oct 11, 2011
    #2
    ok so I decided to uninstall airprint. I went to services and stopped the service. For fun I asked my IP4 to try and print. It reported no printers were found. OK, good, that's what should happen with the service stopped. Next I restarted the service and asked my IP4 to print. The missing Dell printer is now there.
    Don't know why Airprint stopped seeing the Dell and I don't know why it's working again but it is so, good nuff.
     
  3. vahighland macrumors member

    Joined:
    Sep 9, 2009
    Location:
    Atlanta
    #3
    I'm having somewhat similar problems after upgrading to Windows 10 upgrade. With Windows 7, AirPrint always worked even after rebooting the machine and sitting idle. However, with Windows 10 using the same machine and printers, the AirPrint service is flakey. Whenever the machine reboots or sits idle for some period of time, the printers disappear. I have to shut down and restart the AirPrint service to get the printers back. Note that my PC is set to be always on, so it's not a sleep issue.
     
  4. Ristin thread starter macrumors newbie

    Joined:
    Oct 11, 2011
    #4
    So I thought this was fixed but after a day or two my iDevices can't find the Dell printer.
     
  5. Ristin thread starter macrumors newbie

    Joined:
    Oct 11, 2011
    #5
    and now its working again....still no idea why it works sometimes and not others
     

Share This Page