AirTunes problem

Kenny Pollock

macrumors regular
Original poster
Aug 26, 2003
219
0
Hollywood, FL
I just went out and bought an Airport Express tonight, and all seemed well.. until I wanted to play music.

I don't have any wireless cards in my computers, or a wireless router. I plugged the APE (through ethernet) to the router that all of my computers are hooked up to, as well as my internet.

It shows up in my Airport setup, and it shows up in iTunes. I have AirTunes over ethernet checked. When I play through my speakers, all is well. When I select "TV Room" it connects, but the time elapsed moves a second every few minutes. When it plays for a second, it sounds great through the stereo... just wish I could get it working. Can anyone help? :confused:
 

Kenny Pollock

macrumors regular
Original poster
Aug 26, 2003
219
0
Hollywood, FL
No, it's not. That's the problem.
I hit play with "TV Room" selected..

Elapsed time: 0 seconds

3 minutes later...

Elapsed time: 2 seconds

etc.
 
Comment

broken_keyboard

macrumors 65816
Apr 19, 2004
1,144
0
Secret Moon base
Have you tried, for a test, just plugging the Mac directly in to the AE?

I know you won't have Internet, and it wouldn't be the final setup, but if it works you will know the AE is not faulty and it's most likely some compatibility/setting between the router and the AE.
 
Comment

Kenny Pollock

macrumors regular
Original poster
Aug 26, 2003
219
0
Hollywood, FL
broken_keyboard said:
Have you tried, for a test, just plugging the Mac directly in to the AE?

I know you won't have Internet, and it wouldn't be the final setup, but if it works you will know the AE is not faulty and it's most likely some compatibility/setting between the router and the AE.
That works great. Now I don't know how to proceed in fixing it over the router. :confused:
 
Comment

yinyang

macrumors regular
Aug 14, 2003
103
0
sunny brisbane
have you disabled the wireless on the APExpress?

i've beeen working on something similar for work for a windows driven 'thingy' but it worked fine going from PC to a switch to APEx to amp
 
Comment

yinyang

macrumors regular
Aug 14, 2003
103
0
sunny brisbane
in the airport admin utility, on the airport tab, click the base station options and select the 'enable ethernet port'...if you haven't already that is!
 
Comment

Kenny Pollock

macrumors regular
Original poster
Aug 26, 2003
219
0
Hollywood, FL
Done and it doesn't work.

I went out and bought a 16-port switch today, and AirTunes worked fine. Now I restarted everything, and had to facotry-reset it... now in setup utility is recognizes it but there's a problem between my setup utility and the APE.
 
Comment

Sedulous

macrumors 68020
Dec 10, 2002
2,386
1,658
Sounds like an interference problem. Do you have a 2.4 GHz phone, microwave, a lot of neighbors?

Maybe at this point it is best to start over. If you aren't using the AEx as a router, then it is a simple process.

Plug AEx into your router. Using your Mac, start up Airport Admin Utility. Hopefully your AEx shows up in the list... double click it. A new panel opens (with your AEx name at the top of the panel). There are two important things to check (if you've disabled wireless). Under the "Internet" tab, be sure to get your AEx a valid IP number (probably DHCP). I've also turned off distribute IP addresses (under the "Network" tab). The second important thing (as you obviously already know) is the last tab on the right, "Music". Once Airtunes is enabled, everything should work fine. If not, there is something else wrong. I don't think "enable Airtunes over Ethernet" is needed for what you are trying to do.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.