Alarm rings an hour sooner..

Discussion in 'iPhone' started by esadb, Mar 15, 2011.

  1. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #1
    So every since the time change on Sunday my actual iphone alarm rings one hour before. The time is correct on the phone itself and so is the alarm.

    ie. My alarm is set for 7am, but it rings at 6am (which is the old time before the time change..)
     
  2. freeman727 macrumors 6502

    Joined:
    Feb 9, 2009
    #2
    Me too, this happens only with recurring alarms, not non-recurring alarms. I'm on iOS 4.1. I think it is a firmware issue. It's a very idiotic mistake!
     
  3. Zuplar macrumors regular

    Zuplar

    Joined:
    Oct 28, 2007
    Location:
    OKCity
    #3
    Yes, I too have this issue. I think there is a thread with a bunch of people having similar experiences. It's very annoying.
     
  4. LapsangSouchong macrumors 65816

    LapsangSouchong

    Joined:
    Jul 15, 2010
    Location:
    the burrows
    #4
    Delete the alarm and set a new one. Worked for me.

    ALSO: double check your location in both general settings (for the alarm) and in calendar settings (for calendar times and alarms). 4.3 moved my location back to the default of Cupertino.
     
  5. Zuplar macrumors regular

    Zuplar

    Joined:
    Oct 28, 2007
    Location:
    OKCity
    #5
    If he has a jailbreak 4.1 like me and a few others on here, there doesn't seem to be a solution out there.
     
  6. LapsangSouchong macrumors 65816

    LapsangSouchong

    Joined:
    Jul 15, 2010
    Location:
    the burrows
    #6
    Is that it? Note to self: don't jailbreak any time soon.:)
     
  7. Zuplar macrumors regular

    Zuplar

    Joined:
    Oct 28, 2007
    Location:
    OKCity
    #7
    I can't be for sure that those are the only people affected, but I think it has something to do with the version 4.1 more than it does the jailbreak itself.
     
  8. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #8
    Hmm....mine started acting up today. I'm JB'd on 4.1 as well. Never had this issue before. Maybe it's Apple's way of telling us 4.1 users to update already :p
     
  9. izzisdashiz macrumors member

    Joined:
    Jun 19, 2010
    #9
    Been dealing with this too. Very annoying. I deleted the alarms and reset iPhone and still giving me issues.
     
  10. LapsangSouchong macrumors 65816

    LapsangSouchong

    Joined:
    Jul 15, 2010
    Location:
    the burrows
    #10
    Are you jailbroken?
     
  11. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #11
    Of course. Otherwise he would upgrade and fix it. :D
     
  12. Zuplar macrumors regular

    Zuplar

    Joined:
    Oct 28, 2007
    Location:
    OKCity
    #12
    I'd upgrade mine but I need to keep it jailbroke and unlocked and I'm always afraid of getting to aggressive with it.
     
  13. allisfair macrumors member

    Joined:
    Jul 15, 2009
    #13
    i have the issue too on 4.1.

    it only happens w/ recurring alarms so i just programmed my work alarm an hour later. easy temp fix w/o having to upgrade yet.
     
  14. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #14
    Same with me, I had to set it up an hour later so it goes off on time.
    More bugs with the iphone clock/alarm app.
    Im on 4.1 btw.
     
  15. eriknba macrumors member

    Joined:
    Nov 22, 2010
    #15
    unless he's staying at 4.1 because 4.2 deletes all his text messages....like me:(
     
  16. arod757 macrumors newbie

    Joined:
    Sep 11, 2009
    #16
    Same stupid problem here. Fixed it by buying an alarm clock.
     
  17. HKeleher macrumors newbie

    Joined:
    May 28, 2008
    #17
    I've set my alarm an hour early but I would love to get this fixed without having to upgrade. There are a number of features I use that I would miss otherwise so I'm hoping there's a fix coming soon from someone smarter than me!

    ;)
     
  18. uneek1 macrumors regular

    Joined:
    Jun 18, 2009
    #18
    I am 4.1 jailbroken. This also happened to me after daylight savings last week. I had to delete all alarms and set new ones. Fixed the problem. I did reboot after as well.
     

Share This Page