Alarms no longer work on silent?

Discussion in 'iOS 10' started by JayCrev, Aug 7, 2016.

  1. JayCrev macrumors newbie

    Aug 7, 2016
    Hi, first post here!!

    I've lurked the forums for quite a while now and MacRumors in general as a way to keep up with things going on with tech and Apple, and I've upgraded to the latest iOS 10 beta. However, since then, my alarms seem to no longer work when the silent switch is turned on, and I was just wondering whether this is new for anyone else or a glitch that plans to be fixed?

    P.S. I've been able to use my alarms with my silent switch toggled on for the last few years now, and as a student, I've found that feature quite useful, as it meant I never had to really keep track of whether it was on and could still feel vibrations for other notifications.
  2. mikzn macrumors 6502a


    Sep 2, 2013
    did you check the settings? perhaps they were changed somehow during the upgrade? settings < sounds < vibrate on silent?

    Also I prefer the change with buttons - deactivated - this may not be what you wish - but it does keep the volume level of the ringer constant.

    Also make sure vibration is turned on - accessibility ?

    I use the LED to flash for alerts - you might not want that option but it is useful as an addition to the vibration
  3. JayCrev thread starter macrumors newbie

    Aug 7, 2016
    Vibration is turned on, and I do have vibrate on silent on as well along with deaactivated change with buttons. I reset all the settings a couple days ago, and the problem persists. And the LED for alerts doesnt help me much because I can feel my notifications. I just only receive vibrations from alarms and no sounds unless I switch my silent switch off.

    I was just wondering whether that was an intended change or if there was a way to change it back to the way it was for me.
  4. LordQ Suspended


    Sep 22, 2012
    Have you reported the bug to Apple and tried resetting the phone?
  5. Gav2k macrumors G3


    Jul 24, 2009
    I get all alarms when the silent switch is on providing alerts are turned up
  6. JayCrev thread starter macrumors newbie

    Aug 7, 2016
    Yeah, it used to be this way for me as well. Now, all of a sudden, i have to switch it off for me to hear the alarm even with my ringer volume certainly at max volume.

Share This Page