iPod Album Art on ipod

appleguy

macrumors 6502
Original poster
Aug 23, 2002
431
0
Auckland, NZ
Ok I have Album Art on my itunes and it runs fine. its all correct
and yet when I sync down to my ipod the album art is all screwed up and not the correct artwork
I have reset the ipod a couple of times still no luck
any ideas?
 

LizKat

macrumors 603
Aug 5, 2004
5,641
31,309
Catskill Mountains
Right now I have the wrong-art problem on a 2nd gen nano. It's an iPod that I have manually maintained the content on, adding a few things to it now and then. Willie Nelson now graces the artwork for some britpop thing I was listening to the other day. I don't know how or when the art on the Brit track got messed up. It's correct on the computer library. I think I did have the Willie Nelson track on that nano for awhile but it's not on there now. Just his album cover is still hanging around. Sounds like an array-handling glitch.

Suggestions: make sure your iPod's software is up to date. Run the check while you are connected to the internet.

I'm probably just going to restore the nano to factory settings, then make sure I have the lastest greatest nano software, and then START OVER with my track and playlist selections. But I'm dealing with a little nano!

I can see how you might not want to do that if your iPod is a big one. It would be nice if apple had some kind of do-over option on album art, huh? Just ditch it all and get it again, forcing the computer to take it fresh from the library instead of re-using whatever it thinks it has ok on the iPod already.
 

RumMunkey

macrumors 6502a
Nov 3, 2006
693
2
Canada
This is easy. you've just got a corrupt art database on your iPod.

Do this:

Mount your iPod in iTunes. On the summary page, UNcheck "Put album art on iPod".
Sync iPod.
Eject iPod.
Put your left foot in, take your left foot out.
Shake it all about (your foot not your iPod).
Mount your iPod in iTunes again.
This time REcheck "add artwork".
Sync.

All your art will be re-copied to the iPod correctly.
 

LizKat

macrumors 603
Aug 5, 2004
5,641
31,309
Catskill Mountains
Thank You!!!!!!!

This is easy. you've just got a corrupt art database on your iPod.

Do this:

Mount your iPod in iTunes. On the summary page, UNcheck "Put album art on iPod".
Sync iPod.
Eject iPod.
Put your left foot in, take your left foot out.
Shake it all about (your foot not your iPod).
Mount your iPod in iTunes again.
This time REcheck "add artwork".
Sync.

All your art will be re-copied to the iPod correctly.
omg it worked. my green nano thanks you. Willie Nelson thanks you. And, the Arctic Monkeys say they bet you look good on the dancefloor.
 

teitoku

macrumors member
Oct 28, 2006
31
0
Is there a solution for the people out here who don't "sync" and can't get itunes to grab the album art off the internet and have to do it manually?

I copied my songs to my ipod, then manually applied art to them through iTunes, and the fullscreen album art view that you get from clicking the center button on the iPod a few times NEVER EVER shows the correct art, or the same art as the main song view.