Album artwork not showing up in cover flow

Discussion in 'iOS 6' started by campnowhere, Oct 1, 2012.

  1. campnowhere macrumors newbie

    Joined:
    Oct 1, 2012
    #1
    I've been noticing on a few albums that the artwork doesn't show up in cover flow in my music app on my iPhone 5. I never noticed this happening before with my iPhone 4. I've check the affected albums and the artwork is indeed attached to each song, it's in the id3 data and the album artwork shows up on portrait mode on my iPhone 5.

    When I unlock my phone and go into the music app the artwork shows up just fine. It's when I turn my phone in landscape mode to view cover flow that's when my artwork doesn't show for some albums. It's really odd because when I tap on the album and it flips around to show the track list, the artwork appears in the upper right corner like it should. It's just for some reason cover flow can't display it.


    Has anyone had this issue before?
     
  2. Grayburn macrumors 68000

    Grayburn

    Joined:
    Jul 12, 2010
    Location:
    London, England
    #2
    Getting this problem too, strange why it's happening!?!?!
     
  3. Colonel Badger macrumors 6502

    Joined:
    Jun 30, 2008
    #3
    I have the opposite problem.

    Missing app artwork in Portrait in the Album list. All album artwork displays in Landscape in Coverflow. Album artwork also appears if I click on Any Album.

    As you say.. bug!
     
  4. LastOneToKnow, Oct 1, 2012
    Last edited: Oct 1, 2012

    LastOneToKnow macrumors member

    Joined:
    Oct 14, 2011
    Location:
    East Coast, USA
    #4
    I had this same issue once upgrading to iOS 6. Resolved the issue by resyncing my music to the iPad. No missing cover art now. First removed all the music from my iPad 3 by unchecking the "Sync Music" option in iTunes, then syncing. I then checked the "Sync Music" option and performed another sync putting all the same music back on the iPad. Should note as well that I had several other apps presenting issues after upgrading to iOS 6. Those issues were resolved by simply deleting and reinstalling the given app.
     
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    This was a CRITICAL step in resolving the issue for me.

    After updating to iOS 6, the music initially would not play (greyed out), but the iPod knew the names of all songs.
    Forcing a complete sync by adding an additional playlist to the iPod then syncing got all the music back, and playable, but no album art, except in the playlist I had just added for the first time.

    -Figured the iPod's music database was glitched by, or incompatible with, iOS 6, so unchecked "sync Music" option as above, and synced. Rebooted iPod and verified that its iTunes library contained NO MUSIC. Then resynced music from my Mac. All artwork is now back. (Tried same wo first eliminating all music on iPOD, and music wo artwork remained artworkless.)
    This behavior is consistent with a NEW, unglitched, music database being created when music is added to a musicless iPOD.

    I do not use cloud storage for music, but i expect a solution could be more complicated if the copy of database on the cloud is also corrupted.
     
  6. deekay1964 macrumors newbie

    Joined:
    Nov 7, 2012
    #6
    Had a very similar issue. Basically missing art in Coverflow. Would show in Albums and when playing in track..Curiously when you went back to Coverflow from playing the art would be there - but as soon as you scrolled left or right it would disappear.
    Have tried absolutely everything I could find - just normal "Get Info" type updates - changing from "manually managed" library - to itunes library. Deleted itunes library and synced to clear database - used a tag stripper to rip out tags and embedded art - and re-did them all!
    Experienced some other weird things - like would add the library again but only two/three artists would show!
    All pointed to a corrupt music database on the iPod ...
    In the end - what solved it was doing the "clear" and reload as described above - some art work was still missing (say 20% of 50 albums...) - and then I edited the artwork in Microsoft Picture Manager (just did an auto brightness correction) and then reloaded the art with "Get Info" and it worked....sigh...
    So maybe it was a database corruption - some sort of caching issue perhaps - maybe iOS6 is a bit more fussy about it's jpg's .... really no obvious definite cause. But there is a lot of stuff like this in any number of forums - so the Apple guys need to do a bit of work....
     

Share This Page