iPod album Artwork wont appear in Video iPod

mannix87

macrumors 6502
Original poster
Nov 16, 2005
417
0
in the southeast
I'm not sure if this was discussed in a previous thread but I need some help here.

I recently uploaded my collection of album artwork into the iPod (just as I did with my old iPhoto). I even set the preferences to "show artwork in iPod", the artwork works as espected w/ the iTunes. unfortunately, whenever it's unplugged from the computer, the iPod won't show the artwork when a particular song is playing. I've reset the iPod several times to no avail. connected, disconnected, re_connected several times with the iTunes, and reset the settings many times as well, just to be sure. Nothing seems to work. I have no problem w/ the video, works just fine. same with the regular photos. it's just the darn artwork that won't show up. anyone have any ideas? :confused:
 

starnox

macrumors 6502
Apr 15, 2005
363
67
If you ctrl/right click on a song in iTunes and go to 'Get Info' then click the Artwork tab along the top. Does the artwork show up in there?
 

cwedl

macrumors 65816
Jun 5, 2003
1,398
26
I get the same thing when I try and make the album art bigger on my iPod video, To be honest it does really bother that much normally have the ipod in my pocket.
 

martintyler

macrumors newbie
Feb 9, 2005
27
0
I find only some tracks show my album art, and they are definitely there in itunes (not just a case of only adding the album to one song).
 

starnox

macrumors 6502
Apr 15, 2005
363
67
I have added album art to all my songs and they all show up fine on my Video iPod. Not sure what's wrong your end.
 

psimon88

macrumors newbie
Jan 13, 2006
1
0
same problem

Brand new 5G iPod with latest updated software on XP, iTunes latest version.

Album art is on the song and options but it doesn't appear on the iPod. So freaking frustrating..
 

asherman13

macrumors 6502a
Jul 31, 2005
914
0
SF Bay Area, CA
psimon88 said:
Brand new 5G iPod with latest updated software on XP, iTunes latest version.

Album art is on the song and options but it doesn't appear on the iPod. So freaking frustrating..
this is happending to a friend of mine who has a 4G color ipod...any luck yet?
 

mannix87

macrumors 6502
Original poster
Nov 16, 2005
417
0
in the southeast
I checked w/ Apple support, i guess i made a mistake of uploading the artwork straight into the video iPod, (w/c was fine w/ the iPhoto); I was told that the artwork should be part of the song in iTunes first before being uploaded into the video iPod, so I did as suggested and it worked. It sucked a bit as I had to delete first what I already had in the video iPod and then I had to upload (w/ the artwork now) the song/s again. it's not easy if you have 20GB worth of music to sort through :)
 

bzollinger

macrumors 6502a
Aug 1, 2005
542
3
mannix87 said:
I checked w/ Apple support, i guess i made a mistake of uploading the artwork straight into the video iPod, (w/c was fine w/ the iPhoto); I was told that the artwork should be part of the song in iTunes first before being uploaded into the video iPod, so I did as suggested and it worked. It sucked a bit as I had to delete first what I already had in the video iPod and then I had to upload (w/ the artwork now) the song/s again. it's not easy if you have 20GB worth of music to sort through :)

You think 20GB is bad try a full 50GB!!!:mad: :eek: :rolleyes: I tested apple's suggestion for one album and it worked. I then tried to fool it by copying the whole playlist and renaming it. That didn't work. So I just removed everything which only took a few minutes. Now it's uploading everything over again. It would have taken way too long to find out what does and what doesn't have album art and the do it manually.....

I guess as long as it works then it's alright. I think it is very lame of Apple to remove functionality. Because like others I could update just the art on my 4G iPod photo.
 

mannix87

macrumors 6502
Original poster
Nov 16, 2005
417
0
in the southeast
bzollinger said:
You think 20GB is bad try a full 50GB!!!:mad: :eek: :rolleyes: I tested apple's suggestion for one album and it worked. I then tried to fool it by copying the whole playlist and renaming it. That didn't work. So I just removed everything which only took a few minutes. Now it's uploading everything over again. It would have taken way too long to find out what does and what doesn't have album art and the do it manually.....

I guess as long as it works then it's alright. I think it is very lame of Apple to remove functionality. Because like others I could update just the art on my 4G iPod photo.

50GBs!! crappy, indeed. what I forgot to mention was that the problem would not have occurred if my iPod was on auto synch/update setting.
 

bzollinger

macrumors 6502a
Aug 1, 2005
542
3
adn rcd dly said:
my brother and I just figured that out last night too. I told him to update all of the artwork in his library and then do an Automatic Upadate. Worked great.:p
By automatic update do you mean have that playlist automatically updated when your iPod is connected? That is how I have mine set-up and the album art didn't come through. I just removed that playlist (all 50GB), sync'd, then added that play list, and sync'd again. After all of the songs had been copied, the art showed up right.:rolleyes:
 

mannix87

macrumors 6502
Original poster
Nov 16, 2005
417
0
in the southeast
I think it's a program glitch. the Apple tech support mentioned that if at any time you set the iPod for manual managing, even if you set it back to auto synch, the artwork still won't show up; that's why you have to delete everything 1st and upload all the deleted files again (w/ the artwork this time).:rolleyes:
 

asherman13

macrumors 6502a
Jul 31, 2005
914
0
SF Bay Area, CA
mannix87 said:
I think it's a program glitch. the Apple tech support mentioned that if at any time you set the iPod for manual managing, even if you set it back to auto synch, the artwork still won't show up; that's why you have to delete everything 1st and upload all the deleted files again (w/ the artwork this time).:rolleyes:
mine is set for manual managing (i don't have enough space on my comp for my videos) and i see all my artwork....i have a 5G 30GB...
 

adn rcd dly

macrumors 6502
Nov 23, 2004
281
1
Salt Lake City, UT
bzollinger said:
By automatic update do you mean have that playlist automatically updated when your iPod is connected? That is how I have mine set-up and the album art didn't come through. I just removed that playlist (all 50GB), sync'd, then added that play list, and sync'd again. After all of the songs had been copied, the art showed up right.:rolleyes:
no. i mean automatic for the whole damn thing. that is how we did it, i don't know about individual playlists
 

combatcupcake

macrumors newbie
Jan 31, 2006
3
0
I loaded all the artwork for my music in itunes off my hard drive, then I copy to ipod video, artwork shows fine, but then out of nowhere it all disappears, if I plug into comp itunes shows it all, but the ipod wont show any, artwork on enhanced podcasts works fine but not mp3s
and yes show artwork is enabled.
I cant figure it out.
 

combatcupcake

macrumors newbie
Jan 31, 2006
3
0
So I tried the solutions in the other thread, of 2300 mp3s on my ipod, 1 had the white glitch of no artwork and no 'drag artwork here' so i fixed that, and for good measure made sure no tracks had multiple artwork
I did this in itunes ON my ipod, ejected, all of a sudden i can see artwork again
What horrible programming!!!
This is just another reason I hate macs!
 

mcstewart37

macrumors newbie
Oct 12, 2004
8
0
I have a similar problem with my 4gb iPod Nano, but instead of deleting album art it shows the wrong art on certain songs.

I've tried restoring the iPod, which works for about 15 minutes then the problems starts again.

The ablum art shows up in iTunes.

I use MPFreaker to add the art to my songs. BTW, its a great program. You have to pay for it, but I don't work for them I promise: http://www.lairware.com/mpfreaker/

Its pretty annoying about the album art cause thats one reason why I got a new iPizzle...
 

steve_hill4

macrumors 68000
May 15, 2005
1,856
0
NG9, England
combatcupcake said:
So I tried the solutions in the other thread, of 2300 mp3s on my ipod, 1 had the white glitch of no artwork and no 'drag artwork here' so i fixed that, and for good measure made sure no tracks had multiple artwork
I did this in itunes ON my ipod, ejected, all of a sudden i can see artwork again
What horrible programming!!!
This is just another reason I hate macs!
As a user of both Windows and Macs, I have to say this alone is not a basis for hating Macs. Are you using a PC or Mac at the moment? If so, why do I hear so many Mac-haters who have now bought iPods and still can't come up with a decent argument to favour windows over OS X? If you are using a Mac, surely you can think of countless other things that make Macs better than Windows based PCs. If you haven't used Windows in a while, please do and you will re-evaluate your statement.
 

ibilly

macrumors regular
May 2, 2003
248
0
Boulder
martintyler said:
I find only some tracks show my album art, and they are definitely there in itunes (not just a case of only adding the album to one song).
Same problem here... It's very frustrating!
 

striker

macrumors newbie
Feb 8, 2006
1
0
where's the logic?

I have a video ipod 60gb and an ibook G4 and am very happy with both of them. Just now I wanted to add artwork to the songs on my ipod. Similarly to the problems others have posted before, my ipod doesn't show all of the artwork. But the strange thing is that it shows some newly added artwork to SOME already existing songs (even with "manually manage" activated) and on the other hand it doesn't show the artwork of songs I imported from the beginning with the original artwork.
Where's the logic? It's a pity that Apple is giving such miserable support to their top selling product. It seems that their only suggestion for problems is "restore" that's very Microsoft-like isn't it?
Striker
 

denger

macrumors newbie
Feb 23, 2006
1
0
solution

I fixed the problem.
\
what I did was, on the iPod preferences, i 'unchecked' the button show album art on ipod..

it updated itself.

then i 'checked' that same button. it updated itself. I ejected it, and the artwork was back again, where it should be.

furthermore, a good link to get the artwork is

http://tpemble.urfbownd.net/itunes/itunes-search.php

and I use mp3rage to manage my id3s.

seeya
 

Similar threads

Replies
1
Views
620
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.