Aliens vs. Predator 2 (MacPlay) not working on OS X Leopard 10.5

Whitesnake

macrumors newbie
Original poster
Nov 2, 2007
21
0
I recently installed Aliens vs. Predator 2 on my new OS X Leopard installation and I can't seem to get this game to function anymore? :(

I've added the last/latest patch MacPlay released for it and all I get is the screen swirling to the MacPlay logo which is subsequently followed by a black screen with no activity.

The game is PPC code so it utilises Rosetta.

I'm running a Mac Pro with 7300GT GPU & Quad 2.0ghz Woodcrest CPU.

Any ideas? :confused:
 

aidanpendragon

macrumors 6502a
Jul 26, 2005
927
8
No ideas, but thanks for the report.

Now that the OS is "Universal," how does that affect PPC programs that require Rosetta? Does a Universal OS just mean that the install disc carries both PPC and Intel versions and chooses the right one?
 

Whitesnake

macrumors newbie
Original poster
Nov 2, 2007
21
0
I believe so. For the record, Aliens vs. Predator the first game runs completely flawless on Leopard which is also a PPC Binary.
 

ehwood

macrumors newbie
May 27, 2002
12
0
I believe so. For the record, Aliens vs. Predator the first game runs completely flawless on Leopard which is also a PPC Binary.
I was just trying to run the game on my G5 tower with Leopard 10.5.8 and the latest game update installed. Same exact behaviour! It's not an Intel issue, but rather a software one.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.