all applications crash on print command

Discussion in 'Mac Basics and Help' started by Rosencrantz, Aug 11, 2009.

  1. Rosencrantz macrumors newbie

    Joined:
    Aug 11, 2009
    #1
    Started using a mac through work and bought my first 20" imac 8 months ago. Haven't looked back.

    However, since the update to 10.5.7 my imac has crashed applications every time I select the print command in any application that can print.
    I'm printing to an Epson Acculaser C1100 via USB, which worked perfectly before the 10.5.7 update.
    I've searched forums and other sites for a solution but drawn a blank. Here's what I've done so far:
    Twice reinstalled the 10.5.7 update using the Combo update option, repairing permissions before and after.
    Removed the Epson folder from the Printers folder in the library and reinstalled the drivers from the original Epson disk, from the OS X disks that came with the mac, and from the latest driver posted on the Epson site. Each time, no effect.
    Removed all references to Epson from my machine (via a Finder search) and reinstalled the drivers in the three ways listed above.
    Each time the result is the same; when I click the print command or the print icon in any application the application spins the coloured wheel for a while then crashes. Some applications (such as Pages) report that the crash may be related to a file called EpsonPagePDE.plugin, which I've found and deleted from the library several times, to no avail.
    Updated to 10.5.8

    The printer works perfectly from my Mac G4 laptop and from a Windows Vista laptop.
    In just about every other way I'm delighted with my conversion to mac 9 months ago, but this has me beaten.

    Any suggestions ?
     
  2. Rosencrantz thread starter macrumors newbie

    Joined:
    Aug 11, 2009
    #2
    a partial solution

    Since posting my problem and continuing to search other forums for a solution I've found an action that addresses the problem on the Apple Discussions forum, from 2007 !
    Someone posted a similar problem concerning the EpsonPagePDE.plugin file in the printers library. A poster suggested simply removing the offending file from the library, and it solved the symptom of not being able to print, even if it didn't explain why.
    I've done this and my mac is now printing, apparently without any ill effects or loss of function other than the 'printing' icon now looking different. Odd, but I cope with this for having my printer back.

    If anyone has any explanation for this I'd love to know what's going on !
     
  3. edbern macrumors newbie

    Joined:
    Jun 19, 2010
    #3
    Reviving an ancient thread since it still seems to happen -- at least to me -- and once again it was Epson related. I had recently a new Epson printer XP-830, although at first all printers worked fine. Then today I had the symptoms described above. Found this thread and went looking for EpsonPagePDE.plugin in Library. Wasn't there, but I did find some old plists, namely com.epson.ijprinter.EPSON_WorkForce_845_2.ut.plist and com.epson.ijprinter.EPSON_WorkForce_845.ut.plist, for a printer I haven't had in years. Deleted the two plists and voila, problem solved, every app prints again.
     

Share This Page