All apps crash when trying to load....

Discussion in 'iPod touch' started by allinon72, Oct 6, 2008.

  1. allinon72 macrumors newbie

    Joined:
    Sep 24, 2008
    #1
    This is getting irritating. At first, I was having issues with Safari crashing frequently (every 10 minutes or so). Recently, my apps have been problematic. At one point, ALL of my downloaded apps would try to start and then simply go back to the homescreen. Every app was affected, even after rebooting several times. I redownloaded one of the apps, and then they all worked fine. Now, some apps will not work at all. There doesn't seem to be any rhyme or reason as to when some apps will work and when they will not.

    Is anybody else experiencing this?
     
  2. NT1440 macrumors G4

    NT1440

    Joined:
    May 18, 2008
    Location:
    Hartford, CT
  3. rls11286 macrumors newbie

    Joined:
    Sep 23, 2008
    #3
    im running the latest firmware...im not good with numbers i think its the 2.2 but i could be wrong, i just bought the ipod a few weeks ago.

    ive had the same problem in the past with apps crashing and then returning to the home screen. i had to do a complete restore and then load everything back on. i suggest doing this every once in a while anyway just to give your ipod an opportunity to restore itself back to the original settings and as long as you have a back up youre fine
     
  4. slashcrashcup macrumors newbie

    Joined:
    Sep 11, 2008
    #4
    I had this problem with my 2G Ipod Touch and I was really irritated by it. I thought that maybe I had to be in Wifi area to use the apps until someone on here set me straight. It has happened to me twice now. I think I deauthorized my computer and then reauthorized it and it corrected the problem on the next sync (not positive this was the fix though). If not that, then I deleted one program and then resinatlled it. After that (about 3 weeks ago) I have not had any problems with this. (fingers crossed).

    Hope this helps
     
  5. allinon72 thread starter macrumors newbie

    Joined:
    Sep 24, 2008
    #5
    Happened again today....every time I try to start one of my downloaded apps, it crashes and goes back to the homescreen. :mad:
     
  6. gusto5 macrumors member

    Joined:
    Mar 24, 2006
    #6
    Try rebooting the ipod touch (holding power and home until the apple logo comes up again, this is past turning off).

    After that, try reinstalling the applications and see if that helps.
     
  7. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #7
    If gusto5's method still does not work, the restore your iPod in iTunes and DO NOT restore from backup. Then, if that doesn't work, write down what apps you have, delete them all from iTunes and say Move to Trash, then re-download them for free. Then, restore again not from backup, and it should work for sure. If not, go to an Apple store and make a Genius bar appointment.

    Also, is your iPod Touch more than 90% full? Sometimes they have problems when they fill up. Mine had 1.4MB left, and it would not even open a game, so I had to get that up to 600MB, and it still runs pretty sluggishly.
     
  8. LoveTheTouch macrumors newbie

    Joined:
    Oct 8, 2008
    #8
    This is my same problem ...I believe. I did set the time out to 5 minutes on the "Settings" to see if that does anything. I am no expert...just trying stuff.

    I was using bookmarks alot when my blackout happened. I am surfing now, but have not saved anything lately, so I guess I will try again with the bookmarks to see if that is the problem.
     
  9. jordache16 macrumors newbie

    Joined:
    Sep 11, 2008
    #9

    This exact probelm has also happened to me.

    I figured out, like others have, that if you uninstall one app and then reinstall it things seem to go back to normal. It is quite irritating, and if I remember right it was only third party apps that were affected, I could still open up email and safari and other default apps but any app that I had downloaded would not work.
     
  10. Belly-laughs macrumors 6502a

    Belly-laughs

    Joined:
    Jun 8, 2003
    Location:
    you wish
    #10
    I had the exact same problem. With me it was due to iTunes synching with different iTMS account settings than that on the iPhone. De-authorising and re-authorising solved it.
     

Share This Page