ALL Apps Crash

Discussion in 'iPod touch' started by Yaris, Dec 19, 2008.

  1. Yaris macrumors regular

    Joined:
    Jul 26, 2007
    #1
    Recently my iPod touch cannot open any apps from the app store. When I touch the icon, it acts like it's loading for about 4 seconds and then goes to the home screen. I tried resetting the iPod and even upgrading firmware to 2.2. What could the problem be?
     
  2. Yaris thread starter macrumors regular

    Joined:
    Jul 26, 2007
    #2
    Alright nevermind. I restored it and set it up as a new iPod. Now it works.
     
  3. ThunderBull4 macrumors 6502

    Joined:
    Jul 28, 2008
    #3
    When you restore it as a new device, do you lose anything?
     
  4. wakka092 macrumors 6502

    wakka092

    Joined:
    Jun 20, 2007
    #4
    Usually a restart or soft reset (home button + lock button) after installing resolved my problems when I was installing apps and I had this problem.
     
  5. 99MustangGTman macrumors 6502

    Joined:
    Dec 3, 2008
    Location:
    Germantown MD/ Columbus OH
    #5
    Had a similar problem, just restored it and reinstalled the apps, works fine so far *crosses fingers*
     
  6. sjleworthy macrumors 65816

    sjleworthy

    Joined:
    Dec 5, 2008
    Location:
    Penarth, Wales, UK
    #6
    mine occasionally does that. but a quick solution (without restoring) -

    just install another new app (any free one will do), cold re-boot, then all should be fine. just delete that app now. sounds kinda strange and simple, but works all the time for me.
     

Share This Page