All apps except firefox crash to desktop, any ideas?

Discussion in 'Mac Basics and Help' started by SeverinInFurs, Sep 2, 2009.

  1. SeverinInFurs macrumors newbie

    Joined:
    Jul 17, 2008
    #1
    Hello,

    I would like to start off by saying thanks to anybody who even thinks they might have an idea about my problem, I really appreciate it. Now to the point.

    Whenever I open an app, either via finder or the dock, it crashes within seconds of starting and then the "______ quit unexpectedly. Click Reopen to open the application again. Click Report to see more detailed information and send a report to apple." appears. Regardless of my attempt to reopen the apps, I get the same message.

    This is a problem I have been having for ages, but has only now really shown itself to be a huge issue. For the longest time I have been running OSX 1.5.5, which allowed me to run everything fine. It was only when I tried to upgrade to anything above 1.5.5 that I would have this problem. I was quite content therefore, to just wait until snow leopard came out, and just bypass the upgrades and move onto a new OS.

    Well I have snow leopard now, and needless to say the problems persists now that I have installed snow leopard. So I don't know why this is happening but it seems that my mac wont deal with anything higher than 1.5.5.

    Are there any ideas that you guys have as to how I can fix my mac, I am a cheap person by nature and would rather not shell out the money to take my mac in and have it fixed. I have tried reinstalling programs and they still wont work. Maybe if I re-download some of them and try again they will work? I will try this and get back to you.

    Thanks again,
    Cheers,
    -Mark
     
  2. SeverinInFurs thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #2
    Update: Even if I download and install an app, such as Adium, it will still crash.
     
  3. davegregory macrumors regular

    Joined:
    Jul 7, 2009
    Location:
    Burlington, Ontario
    #3
    Honestly, this sounds pretty serious. My best advice, if you're not willing to pay to have it fixed is this.
    Before you do any of this I should tell you to back up your data. Documents, pictures, movies, music, everything you want to keep as this proceedure will delete everything from your machine.

    1) Insert your snow leopard disk into the drive and reboot your machine. While it's rebooting, hold down the "C" key until the drive boots up from CD.

    2) Once you're in the installer, click on "Utilities" in the menu bar and then click "Disk Utility". In the left pane, click on your hard drive that has OS X on it (if you only have one drive click that drive). Then in the right pane go to "Erase". Choose HFS+ Journaled from the drop down bar, then click erase. This is going to warn you about deleting everything from your drive. PLEASE PLEASE PLEASE make sure you've backed up your drive and the backup is working properly...Can't stress that enough. Click yes to the dialogue asking about about erasing the drive.

    3) Once you're done erasing the drive, exit Disk Utility and go back to the installer. Install Snow Leopard, and then boot into it. Your apps should open normally. You can then begin to copy back your documents and files. Install your Applications and you're done.

    I know it's annoying to have to do it, but honestly, I think you're just at that point where it's not going to be fixable without a fresh install
     
  4. SeverinInFurs thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #4
    I was afraid I would have to do that, but if it really is the only option I guess I don't have any choice.

    By the way, I have been looking at the crash reports. I have no idea how to read them, they baffle me in just about every way. I noticed that it listed "Crashed thread: -insert number-". So I looked at said crashed threads and it I saw that this line of script kept reoccurring.

    0x00007fff84243e06 PACEntryStreamCallback(__CFReadStream*, unsigned long, void*)


    Now I would assume that "void*" means that that is where the problem is. I could be VERY VERY wrong though. Does this help at all?
     
  5. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
  6. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #6
    Can you create a new account on the system? Try doing that via sys preferences > accounts.

    Login to that other account and see what happens.
     
  7. SeverinInFurs thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #7
    20" late 2007 imac, 2.4ghz intel core 2 duo, OS X 1.6, 4g ram, 300g HD. Anything else?
     
  8. SeverinInFurs thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #8
    I made a new account and it has the same problem as my regular account.
     
  9. SeverinInFurs thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #9
    Well I am guessing you guys can't help me, but I have some more info just incase you have any new ideas. I downloaded Enemy Territory, it runs fine until the actual game starts. (I don't know if you have played it, but there I can host a game, and everything is fine until the round starts. I can even move around the map in the warm up time before the round starts, but once it does I get the same crash I do with all my other programs.)
     

Share This Page