All Apps quit with iPhone 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RogersDA, Dec 23, 2009.

  1. RogersDA macrumors 6502

    Joined:
    Aug 19, 2009
    #1
    The wife woke this morning to find that no 3rd-party apps will run. Click the icon and they start, but immediately quit. This does not happen with Apple's app (mail, calendar etc.).

    I restarted the phone - no help. I reset the phone - no help.

    We are not at home so we can't resync with the computer where all the iTunes apps are located.

    Any ideas?
     
  2. skubish macrumors 68030

    skubish

    Joined:
    Feb 2, 2005
    Location:
    Ann Arbor, Michigan
    #2
    try deleting an app and redownloading it
     
  3. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #3
    My girlfriend has been having this same issue on her first gen for the past couple days. I restored it (t'was jailbroken), set up as new and tried downloading her apps one by one and it's still doing it. I'm completely clueless...
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #4
    There are a number of fixes for this that may or may not work. Including the fix in the 2nd post, you can try adding an app. You can also try deauthorizing and reauthorizing your computer in iTunes, but that won't help the OP, since he's away from his computer.

    This link may also help:

    http://support.apple.com/kb/TS1702

    Oh, and another member said deleting an app on the computer and resyncing fixed it for him. Who knows?
     
  5. jkozlow3 macrumors 6502a

    Joined:
    Jul 16, 2008
    #5
    I've also had this issue, but only after the phone wouldn't boot properly (stuck on Apple logo). Eventually, I got the phone to reboot after multiple attempts but none of my apps would load. This has happened twice. Both times required placing the phone in DFU mode and setting it up as a new phone (I probably could have synced from a backup, but I never do). I'm worried that it may happen again, and can't figure out if it's a hardware issue or a software one (3.1.2).
     
  6. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #6
    Weird...I've got a 16g 3gs, my wife the 8g 3g...and we both started with the original 2g phones when they came out. I had never seen this issue before...

    I finally convinced my business partner to trade out his Blackberry out of contract and pick up an iPhone. He did this past week, also bought a pair for his teenagers. I helped him get all three set up (for Christmas) and we put 4 or 5 free apps on his new, 16g 3gs. All apps were freebies, just to show him how to do it...but good apps, none-the-less. Dragon Dictation, Google Earth, couple others.

    Anyway, all worked great (this was Monday), today he came into the office and same thing as the OP...all of the 3rd party apps were crashing before launching. I ended up deleting them all and re-installing and all is fine.

    Very strange though.
     
  7. RogersDA thread starter macrumors 6502

    Joined:
    Aug 19, 2009
    #7
    We pretty much had to completely reset the phone (thus killing and removing all apps and settings). Added a few apps back with no problems. We will, of course, resync when we get home. But, alas, she has no music to listen to now.
     

Share This Page