All Bluetooth devices not working on right hand side of iMac

Discussion in 'Mac Accessories' started by Lazarus177, Feb 11, 2013.

  1. Lazarus177 macrumors newbie

    Joined:
    Feb 16, 2011
    #1
    I have a 2011 27 inch imac and recently all my bluetooth devices have stopped working only on the right had side of my iMac.
    If I move them all over to the left, as if I was left handed they all work perfectly.
    Has anyone had this problem? If so, is there any fix?
    Thanks
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    "If I move them all over to the left, as if I was left handed they all work perfectly.
    Has anyone had this problem? If so, is there any fix?"

    I recall reading here about "interference" with Bluetooth caused by proximity to USB3.

    This was particularly noticeable in the early shipments of the 2012 Mac Mini. I believe the "fix" was to add some shielding around the Bluetooth module on them.

    It's possible the iMacs are vulnerable to this, as well.

    Do you have any USB3 devices/cables attached over on the right side?
    What happens if you start shifting the position of devices and cables around?
     
  3. Lazarus177 thread starter macrumors newbie

    Joined:
    Feb 16, 2011
    #3
    There are no USB 3 devices near the iMac. I have a Retina MBP in the room immediately downstairs below the iMac. I'll try and move that but it seems a bit of a long shot.
    I have bluetooth keyboard, trackpad and magic mouse and they all stop working if I move them over to the right hand side. Move them back and they work fine.
    Wouldn't be a problem if I was left handed.
     
  4. Lazarus177 thread starter macrumors newbie

    Joined:
    Feb 16, 2011
    #4
    OK. A quick follow up. I've moved all devices out of the area of the iMac, even my retina MBP from the room down stairs and the problem persists.
    I guess the solution is to use a wired mouse and keyboard, I can live with using the track pad with my left hand.
    Would still like to get it sorted out though.
     

Share This Page