All Emails "gone" in Mail.app

Discussion in 'macOS' started by SrMasterSell, Dec 19, 2007.

  1. SrMasterSell macrumors newbie

    Joined:
    Nov 6, 2007
    Location:
    Tampa, FL, USA
    #1
    I opened Mail.App, and every single email from every folder is completely gone. What do you think happened??? No one deleted them, laptop was with me entire time.

    Worked yesterday, gone today.

    Black MacBook, 2 months old, 2.2, Leapord

    Is the file somewhere?

    Ron
     
  2. MKnight macrumors regular

    MKnight

    Joined:
    Oct 15, 2007
    #2
    Not sure...

    Do you have Time Machine doing regular backups? If so, use the backup files from there...
     
  3. SrMasterSell thread starter macrumors newbie

    Joined:
    Nov 6, 2007
    Location:
    Tampa, FL, USA
    #3
    I don't have time machine hooked up yet.... however, going to start it in a few minutes.

    I did some poking around the hard drive in the Macintosh HD/USERS/RonSell/Mail/Mailboxes/

    and all the emails are still there... (i backed that up real quick) ... however, the emails are not showing up in Mail.App

    Any ideas?

    Thanks guys.

    Ron
     
  4. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #4
    In mail, try mailbox > rebuild on any given mailbox.

    Is there a message about not being able to download them from the server or just a blank empty box?
     
  5. SrMasterSell thread starter macrumors newbie

    Joined:
    Nov 6, 2007
    Location:
    Tampa, FL, USA
    #5
    it is a pop3 mailbox, it has downloaded new messages, but other boxes are just empty.

    Trying your suggestion now.
     
  6. SrMasterSell thread starter macrumors newbie

    Joined:
    Nov 6, 2007
    Location:
    Tampa, FL, USA
    #6
    Fixed

    Thank you so much. Rebuilding the mailboxes worked perfectly.

    Now I have all my email back, and my confidence is back, I have a ton of great attachments I could not afford to loose, so I appreciate your help.

    Ron Sell
     
  7. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #7
    But it doesn't tell you what the problem was. I would recommend you go into the finder and at least make a copy of your entire 'mail' folder.

    You mentioned your mail was here:

    HD/USERS/RonSell/Mail

    Did you mean here?

    HD/USERS/RonSell/Library/Mail
     

Share This Page