All files on my desktop went invisible

Discussion in 'macOS' started by kimjohnsson, Aug 24, 2016.

  1. kimjohnsson macrumors member

    Joined:
    Aug 13, 2013
    #1
    Hi all!

    All of a sudden all my files I had on my desktop seemed to disappear. I thought I might have removed them by mistake, but apparently they are still there. I can see them using Terminal, and creating a new file with the same name as one that already exists there leads to what you would expect in that situation. There are both files and folders that have seemingly disappeared, and there's really nothing special about them. Some mp3's and a couple of other random files. I chmod 777:ed them all, but they still don't show up.

    I created a new folder onto the desktop and moved the files there using Terminal. Now they are in the folder, but Finder doesn't show them.

    In TimeMachine they don't show up either, until I go back a couple of steps, when they suddenly do show up.

    How do I get them to show again?

    Cheers,

    Kim
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    Have you rebooted your Mac since? This may be a glitch in Finder. There is a function that hides all icons too, which you could reverse with:
    Code:
    defaults delete com.apple.finder CreateDesktop && killall -QUIT Finder
     
  3. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #3
    Check the ownership, if you used chmod, try ls -all and see who owns the files vs 'whoami' as you make a new file and compare. chown command lets you also update the owner and group of the said files.
    best of luck. I doubt this is it. It feels like a permission glitch in a plist file or something, cmd/opt/esc and restart finder didn't do the trick either?
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
    You can use InvisibliX to change visibility of files: http://invisiblix.read-write.fr

    P.S. Are you logged on as a different user from before? The desktop is specific to the user.
     
  5. kimjohnsson thread starter macrumors member

    Joined:
    Aug 13, 2013
    #5
    - Have rebooted
    - Same user

    I'll try to look into the suggested actions later this evening

    Thanks,

    Kim
     
  6. kimjohnsson thread starter macrumors member

    Joined:
    Aug 13, 2013
    #6
    Hi guys,

    didn't try any suggestions yet, but I just tried to copy a file to the folder on my desktop here I moved the invisible files. The file I'm copying has the same name as one of the invisible files in that folder. I get this message when trying to copy: The item "xxx.mp3" can't be replaced because it's invisible.

    So there's an error message for it, at least :)

    Cheers,

    Kim
     
  7. Merrie macrumors newbie

    Merrie

    Joined:
    Sep 2, 2016
    #7
    Did you ever get this resolved? I'm having a similar problem. Thanks!
     
  8. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #8
    @Merrie: Try the command I posted above. Also try this one and see whether there is any indiction of ‘hidden’.
    Code:
    ls -laO ~/Desktop
     
  9. kimjohnsson thread starter macrumors member

    Joined:
    Aug 13, 2013
    #9
    Hi!

    No, I've been busy with other things. I thought I'd simply restore them from TimeMachine backup. I know, the lazy approach...

    But I just tried the ls -laO ~/Desktop -command as suggested above, and all files are explicitly labeled as hidden.

    In any case, what can I have done to make this happen? Is there some keyboard shortcut I might have used by mistake?

    Cheers,

    Kim
     
  10. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #10
    I am not sure how it happened. Some program must have set the hidden-flag there. You can easily reverse this with the command:
    Code:
    chflags -R nohidden ~/Desktop
     
  11. kimjohnsson thread starter macrumors member

    Joined:
    Aug 13, 2013
    #11
    OK, just did that. Finders shows them now. Problem solved.

    Thanks :)

    Cheers,

    Kim
     

Share This Page