All Haswell users on Mavericks - Ping issues

Discussion in 'OS X Mavericks (10.9)' started by bp1000, Dec 10, 2013.

  1. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #1
    Do you guys have a ping issue and possibly a throughput issue?

    I have a Haswell iMac and Macbook pro and both machines exhibit really high pings over wifi.

    Open a terminal and try... e.g. :

    press: cmd + spacebar
    type: terminal
    press: enter key
    type: ping www.google.com

    my typical output from my adsl connection

    Code:
    PING www.google.com (173.194.34.84): 56 data bytes
    64 bytes from 173.194.34.84: icmp_seq=0 ttl=58 time=30.052 ms
    64 bytes from 173.194.34.84: icmp_seq=1 ttl=58 time=133.302 ms
    64 bytes from 173.194.34.84: icmp_seq=2 ttl=58 time=43.235 ms
    64 bytes from 173.194.34.84: icmp_seq=3 ttl=58 time=65.324 ms
    64 bytes from 173.194.34.84: icmp_seq=4 ttl=58 time=89.182 ms
    64 bytes from 173.194.34.84: icmp_seq=5 ttl=58 time=112.213 ms
    64 bytes from 173.194.34.84: icmp_seq=6 ttl=58 time=32.163 ms
    64 bytes from 173.194.34.84: icmp_seq=7 ttl=58 time=54.748 ms
    64 bytes from 173.194.34.84: icmp_seq=8 ttl=58 time=77.396 ms
    64 bytes from 173.194.34.84: icmp_seq=9 ttl=58 time=101.273 ms
    64 bytes from 173.194.34.84: icmp_seq=10 ttl=58 time=123.731 ms
    c64 bytes from 173.194.34.84: icmp_seq=11 ttl=58 time=44.756 ms
    64 bytes from 173.194.34.84: icmp_seq=12 ttl=58 time=66.446 ms
    64 bytes from 173.194.34.84: icmp_seq=13 ttl=58 time=90.136 ms
    64 bytes from 173.194.34.84: icmp_seq=14 ttl=58 time=112.819 ms
    This is disappointing. I suspected wifi interference because i ping my routers ip it is the same high pings ruling out my ISP. So if it's local maybe my wifi is the problem. Tried all channels.

    Switching to ethernet solved the issue, but i also have windows 8 on this iMac and i tested wifi ping and it is a solid 29ms - 31ms regardless of how long i run it for. So now it points back to a mavericks issue. If it is a mavericks issue, more people should see the problem.

    My Macbook Pro 13" is exactly the same. So i don't think it is a hardware problem (2 different machines have the problem, but ok in windows).

    Someone suggested this might be a power saving feature but my throughput is behaving erratically too.

    thanks
     
  2. fyzle, Jan 30, 2014
    Last edited: Jan 30, 2014

    fyzle macrumors member

    Joined:
    Aug 1, 2004
    #2
    I wrote an app to fix this.

    I had the same issue, went to an Apple retail store to get the wifi card replaced, and that didn't fix it!

    So, I wrote an app to fix it using solutions / workarounds posted in various forums.

    https://gum.co/PingFixer

    Hope you like it!

    Kevin
     
  3. georgegates5 macrumors newbie

    Joined:
    Jan 25, 2014
    #3
    I once did a university project and I realising pinging from Mac Os X (Was doing my project on Mountain Lion than) was way slower compare to pinging on Windows.

    Windows will receiving a response at a lesser time(faster response) compare to Mac OS X. Not so sure why but according to my lecturer it is due to the way the OS was written.

    I guess there nothing we can do about it but raise this issue to apple engineers.
     
  4. CarreraGuy macrumors regular

    CarreraGuy

    Joined:
    Jan 15, 2013
    #4
    If you are testing your wifi you should ping the first "hop" in your network. Typically home routers have a private LAN ip of 192.168.0.1, but you can figure this out by looking at the first entry of your traceroute results to yahoo, google, etc.

    Then ping the first address you see in the traceroute results. This will give you a better idea of your wifi connection.

    When I ping my local router with a wired connection I see results like:
    PING 192.168.0.1 (192.168.0.1): 56 data bytes

    64 bytes from 192.168.0.1: icmp_seq=0 ttl=64 time=0.752 ms
    64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=0.665 ms
    64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.683 ms

    On my laptop via wireless it varies and I've seen timeouts and some round trip times > 100.00 ms.
     

Share This Page