All I want to do is erase this USB Drive

Discussion in 'Mac Basics and Help' started by estabya, Jan 15, 2016.

  1. estabya macrumors 6502

    estabya

    Joined:
    Jun 28, 2014
    #1
    Last night I used Boot Camp to install Windows 10 on my 2014 Macbook Pro 13". All went smoothly with the installation, but I ran into an issue when I went to format the USB drive I used for the setup. (Formatted as FAT32) I couldn't format it with Disk Utility because it was found to be read only. So I popped into terminal and tried to format it with "diskutil" using superuser permissions. Still wouldn't work. I was getting Error code 69877. So I attempted to use the gpt tool to force delete the partition, but it was telling me "Permission Denied."

    I booted to Windows to try erasing it there. I tried all the methods I know including formatting it through Windows Explorer, Administrator Tools, and diskpart in a command prompt.

    Nothing is working. This drive REALLY doesn't want to be formatted. Any suggestions?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Is this a flash drive or an external usb hard drive? If it is a flash drive, there may be a slide switch on it which makes it read-only.
     
  3. estabya thread starter macrumors 6502

    estabya

    Joined:
    Jun 28, 2014
    #3
    It's a flash drive, but it has no switch.
    --- Post Merged, Jan 17, 2016 ---
    I actually ended up just tossing the drive. It wasn't worth the trouble for an 8Gb drive.
     

Share This Page