All Mail not showing up for Gmail in mail app

Fazzl

macrumors 6502a
Original poster
Aug 13, 2007
567
2
I have 2 gmail accounts both setup using gmail on my iPhone. One of them doesn't show the all mail folder. I deleted and re-aadded but no luck. Any idea?
 

bun.bhay

macrumors member
Dec 6, 2011
58
0
Seatown
Hello.

Try logging into your gmail acct via webmail. Go into acct settings. gmail settings>labels. check to see whether you have the "all mail" folder to "show in imap".
 

sorrentinodc

macrumors newbie
Feb 5, 2018
1
0
What he said! Gotta be the case.
So, this had been driving me crazy for the whole day. I added, deleted, added deleted all freakin day! then it dawned on me. 2 STEP VERIFICATION from Google messes the whole thing up! Follow all other instructions about IMAP on line and disable 2 step verification in your Google + Account. Victory!
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,407
17,053
So, this had been driving me crazy for the whole day. I added, deleted, added deleted all freakin day! then it dawned on me. 2 STEP VERIFICATION from Google messes the whole thing up! Follow all other instructions about IMAP on line and disable 2 step verification in your Google + Account. Victory!
Not quite sure if that really all applied over 6 years ago.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.