*All* mail stored on device?

Discussion in 'iOS 7' started by Dekimasu, Sep 18, 2013.

  1. Dekimasu macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #1
    Prior to today's update, I had my phone set up to sync the previous 100 messages from each of my e-mail accounts.

    Now I have hundreds of megabytes of mail on my phone with iOS 7, and can't figure out a way to limit this syncing.

    Am I missing something?(ーー;)

    ----------

    I mean, missing something besides a way to not have my phone sync mail from years ago.
     
  2. TheRealVertical macrumors newbie

    Joined:
    Sep 8, 2010
    #2
    I'm seeing the same issue, but only for my Comcast mail. My live.com account gives me the ability to control how many days back I want to sync.

    This is a big problem as I don't want 9,000 emails stored on my device.
     
  3. Dekimasu thread starter macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #3
    I have no option (that I can find) for any of my accounts, by either time it number of e-mails.
     
  4. TheRealVertical macrumors newbie

    Joined:
    Sep 8, 2010
    #4
    Surely there has to be some way to control this. I can't not have these email accounts on this device, and I am NOT going through thousands of emails to mark them as read or deleting them.
     
  5. Dekimasu thread starter macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #5
    Ugh. I hate to be one of those guys, and I'm sure I'll get used to this, but I'm kind of wishing I hadn't updated.
     
  6. njchris macrumors regular

    njchris

    Joined:
    Sep 14, 2007
    #6
    I have an option in my hotmail settings for a timeframe, but not for my gmail or icloud email settings. That's strange.
     
  7. stefanie7055 macrumors newbie

    stefanie7055

    Joined:
    May 4, 2013
    Location:
    Ontario
    #7
    The option to limit emails by time is still there..

    Settings > Mail, Contacts, Calendars > Choose the account you wish to change and the option should be at the bottom of the next page, or under the Advance window.
    Works on mine...
     
  8. TheRealVertical macrumors newbie

    Joined:
    Sep 8, 2010
    #8
    No it's only an option for some types of email accounts, not all. This is a big problem.
     
  9. Dekimasu thread starter macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #9
    Nope, no option there, nor is there any advanced window for any of my accounts.
     
  10. duxy macrumors newbie

    duxy

    Joined:
    Mar 2, 2012
    Location:
    Brookline, MA
    #10
    I was able to manage the amount on my exchange account, but not for my iCloud or Gmail...
     
  11. iWally macrumors member

    Joined:
    Jul 16, 2008
  12. Dekimasu thread starter macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #12
    The space requirements for this are prohibitive.

    I'll have to switch back to checking my e-mail via Safari and give up on fetch if this isn't fixed soon. My productivity will take a hit.
     
  13. Dekimasu thread starter macrumors regular

    Joined:
    Jan 17, 2008
    Location:
    Illinois
    #13
    I'm really surprised more people aren't running into this problem.
     
  14. dekadent macrumors member

    dekadent

    Joined:
    Sep 30, 2009
    Location:
    Stockholm, Sweden
    #14
    Perhaps because it only downloads the Inbox folder. I suppose most people use subfolders to organize their mail and don't have 9000 mails in the Inbox.
     
  15. severe macrumors 6502a

    Joined:
    May 23, 2007
    #15
    Yahoo Mail user here. This has been an ongoing issue for me since the first beta. I'd been hoping it would be fixed in the final release. No such luck. :confused:

    There's been many posts/threads regarding this issue, btw. Especially on account of today's release.
     
  16. sim667 macrumors 65816

    Joined:
    Dec 7, 2010
    #16
    I had this problem and found a link that said to go into gmail on a computer browser, in the search bar "is:unread" and complete the search. Then click select all conversations in results ( or words to that effect) then click mark all as read.

    It marked everything in my inbox that was unread as read, and then my iohone mailbox picked it up when I refreshed the inbox
     

Share This Page